aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-07-04 04:59:27 +0000
committerLudovic Courtès <ludo@gnu.org>2022-07-08 17:36:23 +0200
commitf5efde47f7d21f1f35f8b974af8d8f375114a6ea (patch)
treef7daaaddf200ba5d42ea90567e12271b650f7f22 /gnu/packages/gawk.scm
parentb4e74f875f617357719550d6ba3ee818f108a028 (diff)
downloadguix-f5efde47f7d21f1f35f8b974af8d8f375114a6ea.tar
guix-f5efde47f7d21f1f35f8b974af8d8f375114a6ea.tar.gz
gnu: Use 'license:' prefix in (gnu packages gawk).
* gnu/packages/gawk.scm: Import (guix licenses) with 'license:' prefix. (gawk, mawk)[license]: Prefix with 'license:'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 1935e73ab7..91252094b5 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -20,7 +20,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages gawk)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages bash)
#:use-module (gnu packages libsigsegv)
@@ -93,7 +93,7 @@
language for the easy manipulation of formatted text, such as tables of data.
Gawk features many extensions beyond the traditional implementation,
including network access, sorting, and large libraries.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public mawk
(package
@@ -120,4 +120,4 @@ including network access, sorting, and large libraries.")
"@command{mawk} is an interpreter for the Awk programming language.
This version aims to be smaller and faster than GNU Awk, at the expense
of fewer features and extensions.")
- (license gpl2))) ;version 2 only
+ (license license:gpl2))) ;version 2 only