aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-02 00:40:14 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-10 22:14:44 +0100
commite8bf3ced253bcf27e95b4fc46fdf8140550e43ed (patch)
treeec1ddd0bfa84a096261b60ae4cad52aef6ee86f5 /gnu/packages/games.scm
parent9a3fe16b9963d4ec17bfda635722f32586565cc6 (diff)
downloadguix-e8bf3ced253bcf27e95b4fc46fdf8140550e43ed.tar
guix-e8bf3ced253bcf27e95b4fc46fdf8140550e43ed.tar.gz
gnu: Add mupen64plus-video-glide64mk2.
* gnu/packages/games.scm (mupen64plus-video-glide64mk2): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8e0f25f366..2cf721d290 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1536,6 +1536,56 @@ which is capable of accurately playing many games. This package contains the
Glide64 video plugin.")
(license license:gpl2+)))
+(define-public mupen64plus-video-glide64mk2
+ (package
+ (name "mupen64plus-video-glide64mk2")
+ (version "2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mupen64plus/mupen64plus-video-glide64mk2/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ihl4q293d6svba26b4mhapjcdg12p90gibz79b4mx423jlcxxj9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("boost" ,boost)
+ ("libpng" ,libpng)
+ ("mesa" ,mesa)
+ ("mupen64plus-core" ,mupen64plus-core)
+ ("sdl2" ,sdl2)
+ ("zlib" ,zlib)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; The mupen64plus build system has no configure phase.
+ (delete 'configure)
+ ;; Makefile is in a subdirectory.
+ (add-before
+ 'build 'cd-to-project-dir
+ (lambda _
+ (chdir "projects/unix"))))
+ #:make-flags
+ (let ((out (assoc-ref %outputs "out"))
+ (m64p (assoc-ref %build-inputs "mupen64plus-core")))
+ (list "all"
+ (string-append "PREFIX=" out)
+ (string-append "APIDIR=" m64p "/include/mupen64plus")))
+ ;; There are no tests.
+ #:tests? #f))
+ (home-page "http://www.mupen64plus.org/")
+ (synopsis "Mupen64Plus Rice Video plugin")
+ (description
+ "Mupen64Plus is a cross-platform plugin-based Nintendo 64 (N64) emulator
+which is capable of accurately playing many games. This package contains the
+Glide64MK2 video plugin.")
+ (license license:gpl2+)))
+
(define-public nestopia-ue
(package
(name "nestopia-ue")