aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-05 14:01:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-05 14:03:17 -0400
commit79c597c0ee27bc7ca7f5986ef71a90fb62e1422b (patch)
tree1ee6c8f732ea5bacd1ad15648653b26235778896 /gnu/packages/games.scm
parente276f5ed196ae68a98f6747698af1955371b8de1 (diff)
downloadguix-79c597c0ee27bc7ca7f5986ef71a90fb62e1422b.tar
guix-79c597c0ee27bc7ca7f5986ef71a90fb62e1422b.tar.gz
gnu: zsnes: Relocate to (gnu packages emulator).
* gnu/packages/games.scm (zsnes): Move to... * gnu/packages/emulators.scm (zsnes): ... here. Change-Id: I739e0f3b221790b6f780362d884209fff0aed3d7
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm42
1 files changed, 0 insertions, 42 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1305bf426f..d7b79907b0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11775,48 +11775,6 @@ on the pitch of the voice and the rhythm of singing.")
virtual reality devices.")
(license license:expat))))
-(define-public zsnes
- (package
- (name "zsnes")
- (version "2.0.12")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/xyproto/zsnes")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0g9l1ij3p1adkp97wkp0dz44i2xpmsvfpkxvlfkpr7190dibsgsz"))))
- (build-system gnu-build-system)
- (arguments
- (list #:system "i686-linux" ;requires 32 bit libraries to build
- #:tests? #f ;no test suite
- #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "CXX=" #$(cxx-for-target))
- (string-append "PREFIX=" #$output))
- #:phases #~(modify-phases %standard-phases
- (delete 'configure)))) ;no configure script
- (native-inputs (list nasm pkg-config))
- (inputs (list glib libpng mesa ncurses sdl zlib))
- (home-page "https://www.zsnes.com")
- (synopsis "Super Nintendo Entertainment System emulator")
- (description "ZSNES is a @acronym{Super Nintendo Entertainment System,
-SNES} emulator that can play most games at full speed with sound and special
-graphic filters. Some of its features include:
-@itemize
-@item Support for smooth and dynamic image scaling
-@item Support for rewinding and fast-forwarding in-game
-@item JMA compression format
-@item Change the appearance of the GUI
-@item Take screenshots of currently running games
-@item Saving the game at any point by recording the console’s state
-@item Record movies of gameplay which can be played back.
-@end itemize")
- (license license:gpl2+)
- (supported-systems (list "x86_64-linux"))))
-
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar