aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-03-10 15:52:45 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-03-12 18:09:26 +0800
commit2a739c4d210d704c9c1f2a57773f0b0b6198a60a (patch)
tree361763a3ed72855101384359cbe594b4889ce5ac /gnu/packages/games.scm
parent91efdc55f6ea807eb8b2a7a637bc3000c0033917 (diff)
downloadguix-2a739c4d210d704c9c1f2a57773f0b0b6198a60a.tar
guix-2a739c4d210d704c9c1f2a57773f0b0b6198a60a.tar.gz
gnu: manaplus: Update to 2.1.3.17.
* gnu/packages/games.scm (manaplus): Update to 2.1.3.17. [arguments]: Pass "--with-sdl2" as configure-flags. [inputs]: Replace sdl-union with sdl2, sdl2-image, sdl2-mixer, sdl2-net and sdl2-ttf. Change-Id: I223150d559bce21e055b44262c7c97b3ccfa8dc2
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 801e051166..db8d8da0a9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4676,7 +4676,7 @@ on the screen and keyboard to display letters.")
(define-public manaplus
(package
(name "manaplus")
- (version "1.9.3.23")
+ (version "2.1.3.17")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4684,18 +4684,15 @@ on the screen and keyboard to display letters.")
version "/manaplus-" version ".tar.xz"))
(sha256
(base32
- "1ky182p4svwdqm6cf7jbns85hidkhkhq4s17cs2p381f0klapfjz"))))
+ "0ggswsa3xq7lss3j4k7fyzn56sw7hlrwk744i3d9w0n4932nmlg8"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
- (list (string-append "CPPFLAGS=-I"
- (assoc-ref %build-inputs "sdl-union")
- "/include/SDL"))))
+ (list #:configure-flags #~'("--with-sdl2")))
(native-inputs
(list pkg-config))
(inputs
(list glu curl libxml2 mesa
- (sdl-union)))
+ sdl2 sdl2-image sdl2-mixer sdl2-net sdl2-ttf))
(home-page "https://manaplus.org")
(synopsis "Client for 'The Mana World' and similar games")
(description