aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-11 09:28:49 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-11 09:28:49 +0000
commitd85ad082f6c5bc258928ab09aa2a619da6b531ab (patch)
tree6106d865c7b67f1e4cad6ecd6e084658317977de /gnu/packages/games.scm
parent1d5be0b61c80ca9045896d2faa4842955de7cb8b (diff)
downloadguix-fix-red-eclipse.tar
guix-fix-red-eclipse.tar.gz
gnu: red-eclipse: Fix build.fix-red-eclipse
Add a patch from the upstream repository [1] that resolves some errors that prevent the package from building [2]. 1: https://github.com/red-eclipse/base/commit/b16b4963c1ad81bb9ef784bc49 2: error: ‘____gammal_r_finite’ was not declared in this scope * gnu/packages/games.scm (red-eclipse)[source] Add patch. * gnu/packages/patches/red-eclipse-remove-gamma-name-hack.patch: New file * gnu/local.mk (dist_patch_DATA): Add new patch.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5d7c89a880..de53ac798d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2843,7 +2843,9 @@ http://lavachat.symlynx.com/unix/")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1vs9k6f5fgsiy1n72imlqm8khjwm8cryc08zwd4gr7yxlxv45bs0"))))
+ "1vs9k6f5fgsiy1n72imlqm8khjwm8cryc08zwd4gr7yxlxv45bs0"))
+ (patches
+ (search-patches "red-eclipse-remove-gamma-name-hack.patch"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target