aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-12-31 11:26:17 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-01-07 10:39:01 +0800
commite661c1f31d66dcc06316ae58850c8c0773845e6b (patch)
treea18fd4195e1acc488f712771abc98bb6012dc1ab /gnu/packages/game-development.scm
parentfc973ae399584c4a345b6c3080c611d64b321495 (diff)
downloadguix-e661c1f31d66dcc06316ae58850c8c0773845e6b.tar
guix-e661c1f31d66dcc06316ae58850c8c0773845e6b.tar.gz
gnu: bbcsdl: Update to 1.39a.
* gnu/packages/game-development.scm (bbcsdl): Update to 1.39a. [arguments]: Replace bundled "DejaVuSans-Oblique.ttf" with symlink in the 'install' phase. Change-Id: I7b7c8ec8a8216812e1c7a1fab74695b14f4d3ca2
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 73f93a9992..37d8442222 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -3269,16 +3269,16 @@ progresses the level, or you may regenerate tiles as the world changes.")
(define-public bbcsdl
(package
(name "bbcsdl")
- (version "1.35a")
+ (version "1.39a")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/rtrussell/BBCSDL/")
- (commit "b9b2a3eb438cb799edb2766055b3c38e9518e3e3")))
+ (commit "93b0ffae960f4c4f45fdc2202bc6e83ee5ca277c")))
(file-name (git-file-name name version))
(sha256
(base32
- "1d03xmhrl6ba6w0vwfk46mpyc9d0w3bixxj2d4irx7wl7bh3bfic"))))
+ "03ga14k2hbhflnaynbyx9lwlbxlzx3rv6zqq21yhl183s6d4c0wa"))))
(build-system gnu-build-system)
(arguments
(list
@@ -3318,6 +3318,7 @@ progresses the level, or you may regenerate tiles as the world changes.")
inputs (string-append "share/fonts/truetype/" font))
(string-append opt "/lib/" font)))
'("DejaVuSans.ttf" "DejaVuSansMono.ttf"
+ "DejaVuSans-Oblique.ttf"
"FreeSans.ttf" "FreeMono.ttf" "FreeSerif.ttf"))
(mkdir bin)
(symlink (string-append opt "/bbcsdl")