aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-19 12:14:28 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-28 23:14:20 +0200
commitd64d6ea2cf5a1be801be355031fb2cfa5901a92a (patch)
tree180c3b671ab805c64082b7b9a30b5041f343754b /gnu/packages/game-development.scm
parenteb3a7b6646a61db32b021279545dfd56988493b1 (diff)
downloadguix-d64d6ea2cf5a1be801be355031fb2cfa5901a92a.tar
guix-d64d6ea2cf5a1be801be355031fb2cfa5901a92a.tar.gz
gnu: python-renpy: Use G-Expressions.
* gnu/packages/game-development.scm (python-renpy)[arguments]: Convert to list of G-Expressions.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm83
1 files changed, 42 insertions, 41 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 1aae6785b9..431bd5c5e4 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1359,47 +1359,48 @@ developed mainly for Ren'py.")
(("official = official and .*") ""))))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; Ren'py doesn't seem to package tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-commands
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "renpy/editor.py"
- (("xdg-open")
- (string-append (assoc-ref inputs "xdg-utils")
- "/bin/xdg-open")))))
- (add-after 'set-paths 'set-build-vars
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (setenv "RENPY_CYTHON"
- (search-input-file (or native-inputs inputs)
- "/bin/cython"))
- (setenv "RENPY_DEPS_INSTALL" (string-join (map cdr inputs) ":"))))
- (replace 'build
- (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
- ;; The "module" subdirectory contains a python (really cython)
- ;; project, which is built using a script, that is thankfully
- ;; named "setup.py".
- (with-directory-excursion "module"
- (apply (assoc-ref %standard-phases 'build) args))
- ;; The above only builds the cython modules, but nothing else,
- ;; so we do that here.
- (invoke "python" "-m" "compileall" "renpy")))
- (replace 'install
- (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
- ;; Again, we have to wrap the module installation.
- ;; Additionally, we want to install the python code
- ;; (both source and compiled) in the same directory.
- (let* ((out (assoc-ref outputs "out"))
- (site (string-append "/lib/python"
- (python-version
- (assoc-ref inputs "python"))
- "/site-packages")))
- (with-directory-excursion "module"
- (apply (assoc-ref %standard-phases 'install) args))
- (copy-recursively "renpy"
- (string-append out site "/renpy"))
- (delete-file-recursively (string-append out site
- "/renpy/common"))))))))
+ (list
+ #:tests? #f ; Ren'py doesn't seem to package tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-commands
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "renpy/editor.py"
+ (("xdg-open")
+ (string-append (assoc-ref inputs "xdg-utils")
+ "/bin/xdg-open")))))
+ (add-after 'set-paths 'set-build-vars
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (setenv "RENPY_CYTHON"
+ (search-input-file (or native-inputs inputs)
+ "/bin/cython"))
+ (setenv "RENPY_DEPS_INSTALL" (string-join (map cdr inputs) ":"))))
+ (replace 'build
+ (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
+ ;; The "module" subdirectory contains a python (really cython)
+ ;; project, which is built using a script, that is thankfully
+ ;; named "setup.py".
+ (with-directory-excursion "module"
+ (apply (assoc-ref %standard-phases 'build) args))
+ ;; The above only builds the cython modules, but nothing else,
+ ;; so we do that here.
+ (invoke "python" "-m" "compileall" "renpy")))
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
+ ;; Again, we have to wrap the module installation.
+ ;; Additionally, we want to install the python code
+ ;; (both source and compiled) in the same directory.
+ (let* ((out (assoc-ref outputs "out"))
+ (site (string-append "/lib/python"
+ (python-version
+ (assoc-ref inputs "python"))
+ "/site-packages")))
+ (with-directory-excursion "module"
+ (apply (assoc-ref %standard-phases 'install) args))
+ (copy-recursively "renpy"
+ (string-append out site "/renpy"))
+ (delete-file-recursively (string-append out site
+ "/renpy/common"))))))))
(native-inputs (list python-cython))
(inputs
(list ffmpeg