aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-09 16:44:22 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-09 16:46:34 +0100
commit6cae1db889f62051580d5a365f62585412a53a8c (patch)
tree4d3db074d50ca3e2109cced17bec77f207a0c1fd /gnu/packages/game-development.scm
parent410e699e0933653e69d03a4cdadf11854c6723f4 (diff)
parent35e1d9247e39f3c91512cf3d9ef1467962389e35 (diff)
downloadguix-6cae1db889f62051580d5a365f62585412a53a8c.tar
guix-6cae1db889f62051580d5a365f62585412a53a8c.tar.gz
Merge remote-tracking branch 'savannah/master' into mesa-updates
Change-Id: Iad185e2ced97067b3dff8fd722435a6c5e2c00e5
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm64
1 files changed, 30 insertions, 34 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index c65ab74832..8fecd95940 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2020, 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2019 Jethro Cao <jethrocao@gmail.com>
-;;; Copyright © 2020-2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020-2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
@@ -2828,14 +2828,14 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
(define-public ode
(package
(name "ode")
- (version "0.16.4")
+ (version "0.16.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://bitbucket.org/odedevs/ode/downloads/"
"ode-" version ".tar.gz"))
(sha256
- (base32 "0rrl4pn4h3g0ay0i3n61pr6bwyk9vgar17vjal56pj66h617n0vi"))
+ (base32 "0ya6slmy2iysx3fql7w7r56c7gsk93qp1apfjn3raw252vfmx1xs"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -2868,38 +2868,34 @@ computer games, 3D authoring tools and simulation tools.")
(license (list license:lgpl2.1+ license:expat))))
(define-public chipmunk
- (package
- (name "chipmunk")
- (version "7.0.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/slembcke/Chipmunk2D")
- (commit (string-append "Chipmunk-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1qmkn01g06p3rnhmbyffmjns6wj5vhgf9cscigk3wzxcpwv1hyxb"))
- (modules '((guix build utils)))
- (snippet
- #~(begin
- ;; This is fixed in the upstream repository but the fix
- ;; has not been released.
- (substitute* "src/cpHastySpace.c"
- (("#include <sys/sysctl.h>") ""))))))
- (build-system cmake-build-system)
- (arguments
- (list #:tests? #f ;no test
- #:configure-flags
- #~(list "-DBUILD_STATIC=OFF"
- "-DBUILD_DEMOS=OFF")))
- (inputs
- (list freeglut libxmu libxrandr))
- (home-page "https://chipmunk-physics.net/")
- (synopsis "Fast and lightweight 2D game physics library")
- (description "Chipmunk is a simple, lightweight, fast and portable 2D
+ (let ((commit "d0239ef4599b3688a5a336373f7d0a68426414ba")
+ (revision "1"))
+ (package
+ (name "chipmunk")
+ (version (git-version "7.0.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/slembcke/Chipmunk2D")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1910rfnanhna99bhfiyny3ki7aip2i9p4jzmwsfcg16m9gip5fd6"))
+ (modules '((guix build utils)))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ;no test
+ #:configure-flags
+ #~(list "-DBUILD_STATIC=OFF"
+ "-DBUILD_DEMOS=OFF")))
+ (inputs
+ (list freeglut libxmu libxrandr))
+ (home-page "https://chipmunk-physics.net/")
+ (synopsis "Fast and lightweight 2D game physics library")
+ (description "Chipmunk is a simple, lightweight, fast and portable 2D
rigid body physics library written in C.")
- (license license:expat)))
+ (license license:expat))))
(define-public box2d
(package