aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTakeV <takev@disroot.org>2023-07-27 21:26:37 -0700
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-05 13:51:19 +0200
commit4739e6844cfbf815357019faf708d3c266137acc (patch)
tree9a0b9831592c304272c04eaaace90bebde4c7eb8 /gnu/packages/game-development.scm
parentea17bc5b20ca781bca6231506e2ffd329f53a266 (diff)
downloadguix-4739e6844cfbf815357019faf708d3c266137acc.tar
guix-4739e6844cfbf815357019faf708d3c266137acc.tar.gz
gnu: godot: Use system brotli.
* gnu/packages/game-development.scm (godot)[source]: Do not preserve brotli. [arguments]<#:scons-flags>: Add “builtin_brotli=no”. [inputs]: Add brotli. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index f4b1a1e1e3..5771b7530f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2017,10 +2017,6 @@ scripted in a Python-like language.")
"assimp"
"astcenc"
"basis_universal"
- ;; TODO: Can unbundle once
- ;; <https://github.com/godotengine/godot/pull/79101>
- ;; is merged
- "brotli"
;; Godot needs ca-certificates.crt, but that is
;; not available in build environment
"certs"
@@ -2067,6 +2063,7 @@ scripted in a Python-like language.")
"use_volk=no"
;; Avoid using many of the bundled libs.
;; Note: These options can be found in the SConstruct file.
+ "builtin_brotli=no"
"builtin_embree=no"
"builtin_enet=no"
"builtin_freetype=no"
@@ -2193,6 +2190,7 @@ scripted in a Python-like language.")
(list pkg-config))
(inputs
(list alsa-lib
+ brotli
dbus
embree
enet