aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-12-31 15:08:45 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-07 10:06:42 +0100
commit3b4e71c4734910f1850b40fa636cd7d52f2b0b5e (patch)
tree8a6eeed944370917fddc207f8276b223b75a922d /gnu/packages/game-development.scm
parent11136fb0ad90937516ce0421a352e3a4513fca3b (diff)
downloadguix-3b4e71c4734910f1850b40fa636cd7d52f2b0b5e.tar
guix-3b4e71c4734910f1850b40fa636cd7d52f2b0b5e.tar.gz
gnu: dds: Update to 2.9.0-1.d2bc4c2.
* gnu/packages/game-development.scm (dds): Update to 2.9.0-1.d2bc4c2. Change-Id: I3c6db4e81d70112f020f2d7a0f7db26069c7591f Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm124
1 files changed, 63 insertions, 61 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 37d8442222..ea1adf0ecf 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -196,69 +196,71 @@ is used in some video games and movies.")
(license license:zlib)))
(define-public dds
- (package
- (name "dds")
- (version "2.9.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dds-bridge/dds")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1iv09qic43nvla02lm8zgnkqpjgnc95p8zh3wyifmnmlh1rz02yj"))))
- (build-system gnu-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "src")))
- (replace 'configure
- ;; Configuration is done by copying the appropriate
- ;; make file in the working directory. There is no
- ;; configure script.
- (lambda _
- (copy-file "Makefiles/Makefile_linux_shared"
- "Makefile")))
- (replace 'check
- ;; There is no "check" traget. We must compile
- ;; a "dtest" program and apply it on a data set.
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (install-file "libdds.so" "../test")
- (with-directory-excursion "../test"
- (copy-file "Makefiles/Makefile_linux"
- "Makefile")
- (substitute* "Makefile"
- (("-Werror") ""))
- (invoke "make")
- (invoke "./dtest" "-f" "../hands/list100.txt")))))
- (replace 'install
- ;; "install" target merely moves ".so" file around
- ;; the source directory. We install it in the store,
- ;; along with all shipped documentation (which cannot
- ;; be built from source unfortunately).
- (lambda _
- (install-file "libdds.so"
- (string-append #$output "/lib"))
- (let ((doc (string-append #$output
- "/share/doc/"
- #$name "-" #$version)))
- (install-file "../LICENSE" doc)
- (copy-recursively "../doc" doc)))))))
- (native-inputs
- (list gawk procps))
- (inputs
- (list boost))
- (home-page "https://privat.bahnhof.se/wb758135/")
- (synopsis "Double dummy solver for the bridge card game")
- (description "DDS is a double-dummy solver of bridge hands. It supports
+ (let ((commit "d2bc4c2c703941664fc1d73e69caa5233cdeac18")
+ (revision "1"))
+ (package
+ (name "dds")
+ (version (git-version "2.9.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dds-bridge/dds")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ishbb69cvyv96xdxshnly0m5ydwljgdf8fwa1cr9rj2qj40q4rm"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "src")))
+ (replace 'configure
+ ;; Configuration is done by copying the appropriate
+ ;; make file in the working directory. There is no
+ ;; configure script.
+ (lambda _
+ (copy-file "Makefiles/Makefile_linux_shared"
+ "Makefile")))
+ (replace 'check
+ ;; There is no "check" traget. We must compile
+ ;; a "dtest" program and apply it on a data set.
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (install-file "libdds.so" "../test")
+ (with-directory-excursion "../test"
+ (copy-file "Makefiles/Makefile_linux"
+ "Makefile")
+ (substitute* "Makefile"
+ (("-Werror") ""))
+ (invoke "make")
+ (invoke "./dtest" "-f" "../hands/list100.txt")))))
+ (replace 'install
+ ;; "install" target merely moves ".so" file around
+ ;; the source directory. We install it in the store,
+ ;; along with all shipped documentation (which cannot
+ ;; be built from source unfortunately).
+ (lambda _
+ (install-file "libdds.so"
+ (string-append #$output "/lib"))
+ (let ((doc (string-append #$output
+ "/share/doc/"
+ #$name "-" #$version)))
+ (install-file "../LICENSE" doc)
+ (copy-recursively "../doc" doc)))))))
+ (native-inputs
+ (list gawk procps))
+ (inputs
+ (list boost))
+ (home-page "https://privat.bahnhof.se/wb758135/")
+ (synopsis "Double dummy solver for the bridge card game")
+ (description "DDS is a double-dummy solver of bridge hands. It supports
single-threading and multi-threading for improved performance. DDS
offers a wide range of functions, including par-score calculations.")
- (license license:asl2.0)))
+ (license license:asl2.0))))
(define-public deutex
(package