aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-05-07 19:50:49 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-05-13 17:35:19 +0800
commit1fa30c597b220bc14681ac1463371377af85a323 (patch)
tree0a507cccc53a052dd930878be150410920a2efe0 /gnu/packages/game-development.scm
parent733c8a6c54d9446f4fc3b66196216734fef99fee (diff)
downloadguix-1fa30c597b220bc14681ac1463371377af85a323.tar
guix-1fa30c597b220bc14681ac1463371377af85a323.tar.gz
gnu: raylib: Fix audio and use system glfw.
* gnu/packages/game-development.scm (raylib)[inputs]: Use glfw and pluseaudio. [arguments]: Set flags for glfw and pulseaudio.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 560765fd64..0d519fb7ed 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2868,14 +2868,22 @@ progresses the level, or you may regenerate tiles as the world changes.")
(arguments
(list #:tests? #f ;no test
#:configure-flags
- #~(list "-DBUILD_SHARED_LIBS=ON" )))
- (inputs (list alsa-lib
- libx11
- libxrandr
- libxi
- libxinerama
- libxcursor
- mesa))
+ #~(list "-DBUILD_SHARED_LIBS=ON"
+ "-DUSE_EXTERNAL_GLFW=ON"
+ "-DCMAKE_C_FLAGS=-lpulse")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'configure-miniaudio
+ ;; Use PulseAudio as raudio backend.
+ (lambda _
+ (substitute* "src/raudio.c"
+ (("^#include \"external/miniaudio\\.h\"") "
+#define MA_NO_RUNTIME_LINKING
+#define MA_ENABLE_ONLY_SPECIFIC_BACKENDS
+#define MA_ENABLE_PULSEAUDIO
+#include \"external/miniaudio.h\"
+")))))))
+ (inputs (list glfw pulseaudio))
(native-inputs (list pkg-config))
(synopsis "C library for videogame programming")
(description