aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorrennes <rennes@openmailbox.org>2017-02-14 23:22:07 -0600
committerLeo Famulari <leo@famulari.name>2017-03-04 23:15:05 -0500
commitafa595350bdfab8f65bece34d7303bf8c9b981da (patch)
tree0d4fe682a4746925d1224be31ebc819e2ae8b31c /gnu/packages/ftp.scm
parent40c611a41df35877c91a6b1ef66bdc84e6355ec7 (diff)
downloadguix-afa595350bdfab8f65bece34d7303bf8c9b981da.tar
guix-afa595350bdfab8f65bece34d7303bf8c9b981da.tar.gz
gnu: Add libfilezilla.
* gnu/packages/ftp.scm (libfilezilla): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 7380fcfc3b..3f3a0491ca 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,10 @@
#:use-module (guix packages)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages readline)
@@ -159,3 +164,25 @@ maintaining a web page or other FTP archive. It synchronizes a set of
local files to a remote server by performing uploads and remote deletes
as required.")
(license gpl2+)))
+
+(define-public libfilezilla
+ (package
+ (name "libfilezilla")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.filezilla-project.org/"
+ name "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0340v5xs48f28q2d16ldb9359dkzlhl4l449mgyv3qabnlz2pl21"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("cppunit" ,cppunit)))
+ (home-page "https://lib.filezilla-project.org")
+ (synopsis "Cross-platform C++ library used by Filezilla client")
+ (description
+ "This package provides some basic functionality to build high-performing,
+platform-independent programs.")
+ (license gpl2+)))