aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-27 09:14:14 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-27 09:14:14 +0900
commitd8298b37af7577aa3fba6bc45048d04a33f59b1f (patch)
tree8c463d82ba17e90e5edc9789801f286dae71d206 /gnu/packages/freedesktop.scm
parent8172b25ea22762b361b14600292c154a10579b47 (diff)
downloadguix-d8298b37af7577aa3fba6bc45048d04a33f59b1f.tar
guix-d8298b37af7577aa3fba6bc45048d04a33f59b1f.tar.gz
Revert "gnu: xdg-desktop-portal: Improve style."
This reverts commit add9662686f74a39ea4f3fa75c5b81b1debb9a67.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 9cc6c8171b..289c4ea281 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3025,6 +3025,26 @@ compatible with the well-known scripts of the same name.")
;; Disable portal tests since they try to use fuse.
(patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
(build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin")
+ ("gettext" ,gettext-minimal)
+ ("python" ,python)
+ ("python-dbusmock" ,python-dbusmock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-xdist" ,python-pytest-xdist)))
+ (inputs
+ `(("bubblewrap" ,bubblewrap)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("glib" ,glib)
+ ("flatpak" ,flatpak)
+ ("fontconfig" ,fontconfig)
+ ("json-glib" ,json-glib)
+ ("libportal" ,libportal)
+ ("dbus" ,dbus)
+ ("geoclue" ,geoclue)
+ ("pipewire" ,pipewire)
+ ("fuse" ,fuse)))
(arguments
`(#:configure-flags
(list "-Dsystemd=disabled")
@@ -3038,26 +3058,6 @@ compatible with the well-known scripts of the same name.")
(find-files "po" "\\.po$"))))
(add-after 'unpack 'set-home-directory
(lambda _ (setenv "HOME" "/tmp"))))))
- (inputs
- (list bubblewrap
- dbus
- flatpak
- fontconfig
- fuse
- gdk-pixbuf
- geoclue
- glib
- json-glib
- libportal
- pipewire))
- (native-inputs
- (list gettext-minimal
- `(,glib "bin")
- pkg-config
- python
- python-dbusmock
- python-pytest
- python-pytest-xdist))
(native-search-paths
(list (search-path-specification
(variable "XDG_DESKTOP_PORTAL_DIR")