aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 20:07:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-16 11:16:01 -0400
commit8d6838dfcdff7b5973a025a17b190636e5c105e7 (patch)
tree98d2d20a0735536f4d1c64f698357331b70a28bf /gnu/packages/freedesktop.scm
parent9c2b2a010558057428d1ab1c28a2e8e59e2546aa (diff)
downloadguix-8d6838dfcdff7b5973a025a17b190636e5c105e7.tar
guix-8d6838dfcdff7b5973a025a17b190636e5c105e7.tar.gz
gnu: maliit-framework: Disable two mimpluginmanager tests.
* gnu/packages/freedesktop.scm (maliit-framework) [arguments]: Override the check phase to disable the ft_mimpluginmanager and ut_mimpluginmanager tests.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6bff3fa967..648ebad408 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -406,6 +406,20 @@ inappropriate content.")
(base32
"1dkjxvfxg56hfy70j6ibfklfyv57jiha4vgc3ggl60r5kjx65s5b"))))
(build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The Ft_MIMPluginManager::testPluginDescriptions test fails
+ ;; with a QFATAL error: received signal 11, while
+ ;; ut_mimpluginmanager fails at least on powerpc64le with a
+ ;; subprocess aborted error (see:
+ ;; https://github.com/maliit/framework/issues/120).
+ (invoke "ctest" "-E"
+ "(ft_mimpluginmanager|ut_mimpluginmanager)")))))))
(native-inputs (list extra-cmake-modules
wayland-protocols
pkg-config