aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-06-22 20:33:17 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-06-24 21:43:00 +0200
commit0ccafddca9d9fea971c5baeabf03d8e5123cc4bd (patch)
tree0636d9124289be32648e13f94f7d32b78ca122bd /gnu/packages/freedesktop.scm
parentda24d067d0954cc8f8d75fa9099ad6d8a01e1098 (diff)
downloadguix-0ccafddca9d9fea971c5baeabf03d8e5123cc4bd.tar
guix-0ccafddca9d9fea971c5baeabf03d8e5123cc4bd.tar.gz
gnu: shared-mime-info: Move to (gnu packages freedesktop).
* gnu/packages/gnome.scm (shared-mime-info): Move to … * gnu/packages/freedesktop.scm: … here. * gnu/packages/gnuzilla.scm: Use (gnu packages freedesktop). * gnu/packages/kde-games.scm: Ditto. * gnu/packages/kde-multimedia.scm: Ditto. * gnu/packages/kde-pim.scm: Ditto. * gnu/packages/kde-utils.scm: Ditto. * gnu/packages/maths.scm: Ditto. * gnu/packages/mp3.scm: Ditto. * gnu/packages/ruby.scm: Ditto. * guix/profiles.scm (xdg-mime-database): Adjust to new location. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6385741d89..bd3df9ee68 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -465,6 +465,39 @@ method framework.")
display servers. It supports many different languages and emoji.")
(license license:gpl3+)))
+(define-public shared-mime-info
+ (package
+ (name "shared-mime-info")
+ (version "1.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gitlab.freedesktop.org/xdg/shared-mime-info/uploads/"
+ "b27eb88e4155d8fccb8bb3cd12025d5b/shared-mime-info-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "146vynj78wcwdq0ms52jzm1r4m6dzi1rhyh3h4xyb6bw8ckv10pl"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; The build system appears not to be parallel-safe.
+ '(#:parallel-build? #f))
+ (inputs
+ (list glib libxml2))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://www.freedesktop.org/wiki/Software/shared-mime-info")
+ (synopsis "Database of common MIME types")
+ (description
+ "The shared-mime-info package contains the core database of common types
+and the update-mime-database command used to extend it. It requires glib2 to
+be installed for building the update command. Additionally, it uses intltool
+for translations, though this is only a dependency for the maintainers. This
+database is translated at Transifex.")
+ (license license:gpl2+)))
+
(define-public xdg-utils
(package
(name "xdg-utils")