aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-01-17 20:50:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 15:06:50 +0000
commit121bf9b296d1bcb24c4dff2ddde181f22f78ed89 (patch)
tree179e18f96d16187b2b1e89f96f70c6d7e4051926 /gnu/packages/fontutils.scm
parent354de73fa45bdf045ccca8461dab500f5347b06c (diff)
downloadguix-121bf9b296d1bcb24c4dff2ddde181f22f78ed89.tar
guix-121bf9b296d1bcb24c4dff2ddde181f22f78ed89.tar.gz
gnu: fcft: Enable shaping support.
While utf8proc is an optional dependency, it is required for shaping support. Without utf8proc, fcft_rasterize_text_run_utf32() is a no-op. This is a popular function used—among other things—by yambar, foot, fuzzel and fnott. Therefore, many other Linux distributions (Arch, Debian, Fedora, …) enable this feature and I think it would be nice to have in Guix as well. * gnu/packages/fontutils.scm (fcft): Depend on utf8proc. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I7489dbc7a42ffcca509d090df7d2a6250bf996ff
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 8d3c017107..299fe87edf 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
+;;; Copyright © 2024 Sören Tempel <soeren@soeren-tempel.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,6 +74,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (gnu packages tex)
+ #:use-module (gnu packages textutils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix gexp)
#:use-module (guix packages)
@@ -1911,6 +1913,7 @@ maintain the Noto Fonts project.")
(list check pkg-config scdoc))
(propagated-inputs
(list ;; Required by fcft.pc.
+ utf8proc
fontconfig
freetype
harfbuzz