aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorchris <chris@bumblehead.com>2023-08-30 23:52:13 -0700
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-05 19:50:42 -0400
commit95558f555abe08b4a6019290be70bed76161e968 (patch)
treeb91746cca3f6a12dacf9707bbc78e3471c545079 /gnu/packages/fonts.scm
parent418edcd6d8e4fdd1f6027f3545b3a0170142be7e (diff)
downloadguix-95558f555abe08b4a6019290be70bed76161e968.tar
guix-95558f555abe08b4a6019290be70bed76161e968.tar.gz
gnu: Add fonts-tlwg.
* gnu/packages/fonts.scm (fonts-tlwg): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 3cdfb7500a..db4d41e2d8 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 chris <chris@bumblehead.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3411,3 +3412,25 @@ better code & UI. It is inspired by casual script signpainting, but designed
primarily to meet the needs of programming environments and application
interfaces.")
(license license:silofl1.1)))
+
+(define-public fonts-tlwg
+ (package
+ (name "fonts-tlwg")
+ (version "0.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tlwg/" name
+ "/releases/download/v" version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "00mv8rmjpsk8jbbl978q3yrc2pxj8a86a3d092563dlc9n8gykkf"))))
+ (native-inputs (list fontforge))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/tlwg/fonts-tlwg/")
+ (synopsis "Collection of scalable Thai fonts")
+ (description "Fonts-TLWG is a collection of Thai scalable fonts. Its goal
+is to provide fonts that conform to existing standards and recommendations, so
+that it can be a reference implementation.")
+ (license license:gpl2+)))