aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2023-08-31 11:47:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-05 19:50:44 -0400
commit766342dc3510a0623e986eeeca19826294e67748 (patch)
treeea60137b78de5910ff0c49e489a10e467b3bd030 /gnu/packages/fonts.scm
parent2ae57c98a9e50105fc2f967b5350c63ff8f22dbd (diff)
downloadguix-766342dc3510a0623e986eeeca19826294e67748.tar
guix-766342dc3510a0623e986eeeca19826294e67748.tar.gz
gnu: Add font-junicode.
* gnu/packages/fonts.scm (font-junicode): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index db4d41e2d8..93c1308d54 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -43,7 +43,7 @@
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021-2023 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
-;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022-2023 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Kitzman <kitzman@disroot.org>
;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
@@ -1911,6 +1911,36 @@ programming. Iosevka is completely generated from its source code.")
version of the original, designed for enhanced readability.")
(license license:silofl1.1)))
+(define-public font-junicode
+ (package
+ (name "font-junicode")
+ (version "2.003")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/psb1558/Junicode-font")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qg1qwk294p2hgq2gbyhfwwdas1xbkfz3csxf5jz4xqiskn4skgl"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/psb1558/Junicode-font")
+ (synopsis "Unicode font for medievalists, linguists, and others")
+ (description "The Junicode font was developed for students and scholars of
+medieval Europe, but its large glyph repertoire also makes it useful as a
+general-purpose font. Its visual design is based on the typography used by
+Oxford University Press in the late 17th and early 18th centuries. The font
+implements the @acronym{MUFI, Medieval Unicode Font Initiative} recommendation
+for encoding ligatures, alternative letter forms, and other features of
+interest to medievalists using Unicode's Private Use Area.
+
+Junicode 2 is a major reworking of the font family. Its OpenType programming
+has been rebuilt to support the creation of searchable, accessible electronic
+documents using the @acronym{MUFI} characters. The family includes five
+weights and five widths in both Roman and Italic, plus variable fonts.")
+ (license license:silofl1.1)))
+
(define-public font-sarasa-gothic
(package
(name "font-sarasa-gothic")