aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-17 01:12:40 +0100
committerMarius Bakke <marius@gnu.org>2022-12-17 17:08:51 +0100
commitec76f45d30ad24f76a4274d92e79231c3d9bc7de (patch)
treeb6b9d8688fdf365ae7df0a82778b493a06a89e07 /gnu/packages/firmware.scm
parentf7793ce0e0d4e45459ed1cd485c7ff39f3bcd90d (diff)
downloadguix-ec76f45d30ad24f76a4274d92e79231c3d9bc7de.tar
guix-ec76f45d30ad24f76a4274d92e79231c3d9bc7de.tar.gz
gnu: SeaBIOS: Simplify build.
* gnu/packages/firmware.scm (seabios)[arguments]: Don't install bios.bin twice. Drop redundant append step.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 781d8ae004..a4e43e71ec 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -450,7 +450,7 @@ executing in M-mode.")
(string-drop-right entry 2))
(format port "CONFIG_~a~%" entry)))
(cons "BUILD_VGABIOS=y" config))))
- (apply invoke "make" (append flags '("oldnoconfig")))
+ (apply invoke "make" "oldnoconfig" flags)
(apply invoke "make" flags)
(link (string-append target "/bios.bin")
(string-append "out/" target ".bin")))))
@@ -469,8 +469,6 @@ executing in M-mode.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(fmw (string-append out "/share/firmware")))
- (mkdir-p fmw)
- (copy-file "out/bios.bin" (string-append fmw "/bios.bin"))
(for-each (lambda (bios)
(install-file bios fmw))
(find-files "out" "\\.bin$"))