aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2024-02-29 16:20:46 +0100
committerLudovic Courtès <ludo@gnu.org>2024-04-17 12:13:02 +0200
commitc3aba93823583bfebae93ce1b9484a0c37fb3008 (patch)
tree0aea45a462700abb5784b181813237c838485f95 /gnu/packages/firmware.scm
parentaf181ac5d14ae639499ff1a57b5a9d615aee0ed2 (diff)
downloadguix-c3aba93823583bfebae93ce1b9484a0c37fb3008.tar
guix-c3aba93823583bfebae93ce1b9484a0c37fb3008.tar.gz
gnu: ath9k-htc-firmware: Allow using other targets.
* gnu/packages/firmware.scm (ath9k-htc-firmware): Override the TARGET environment variable in the configure script to use xtensa-elf. * gnu/packages/patches/ath9k-htc-firmware-objcopy.patch: Adapt to use TARGET environment variable for objcopy. Change-Id: Ia44f0f25dde532b90168f2f2456412a43ac9af24 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 1d89dfba00..7923f5c908 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -121,6 +121,7 @@
;; 'configure' is a simple script that runs 'cmake' with
;; the right flags.
(substitute* "configure"
+ (("^TARGET.*$") "TARGET=xtensa-elf\n")
(("^TOOLCHAIN=.*$")
(string-append "TOOLCHAIN="
(assoc-ref (or native-inputs inputs) "cross-gcc")