aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-20 15:48:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 00:06:13 -0400
commit2f0e21e9fab05945d60bc133a1e0bcc1f4a2c588 (patch)
treed2a7e096997b73d4854f1d5cc79b728bd91f429f /gnu/packages/firmware.scm
parent26025fa8022296a199a7de0f0928c939394f6a6d (diff)
downloadguix-2f0e21e9fab05945d60bc133a1e0bcc1f4a2c588.tar
guix-2f0e21e9fab05945d60bc133a1e0bcc1f4a2c588.tar.gz
gnu: Add qmk-firmware-ergodox-ez-dvorak-42-key.
* gnu/packages/firmware.scm (qmk-firmware-ergodox-ez-dvorak-42-key): New variable.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 1663164894..d07b329d26 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1436,3 +1436,14 @@ Layer 2 contains multimedia and mouse keys. See the
keymap definition, or the
@url{https://configure.ergodox-ez.com/ergodox-ez/layouts/JwwW/latest/0,
ErgoDox EZ Configurator} page."))
+
+(define-public qmk-firmware-ergodox-ez-dvorak-42-key
+ (make-qmk-firmware "ergodox_ez" "dvorak_42_key" #:description "\
+This is a Dvorak-based layout for the ErgoDox EZ. Its basic key layout is
+similar to the Atreus @samp{dvorak_42_key} layout; in fact this layout was
+created for seamless switching between the ErgoDox EZ and Atreus keyboards.
+On the base layer, the keys that don't exist on the Atreus are mapped to MEH
+shortcuts and can be interpreted by your window managher. This layout only
+makes use of the 42 keys that the Atreus also has for the main functionality.
+See the @file{keyboards/atreus/keymaps/dvorak_42_key/keymap.c} source file for
+the keymap definition."))