aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorAttila Lendvai <attila.lendvai@gmail.com>2023-09-27 17:47:29 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-10-03 16:02:02 +0200
commit75aff50fce49a92a54844d997ebab5b1343c73a6 (patch)
tree8147d3851b8acc3e6912897e0dd98b0671f8e37c /gnu/packages/finance.scm
parented363d6ddbd36f37524af35ab5961ea72c1de62c (diff)
downloadguix-75aff50fce49a92a54844d997ebab5b1343c73a6.tar
guix-75aff50fce49a92a54844d997ebab5b1343c73a6.tar.gz
gnu: python-trezor-agent: Update to 0.14.7.
* gnu/packages/finance.scm (python-trezor-agent): Update to 0.14.7. [native-inputs]: Add python-bech32 and python-cryptography. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7f8a1edfe7..10f5e35673 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -925,7 +925,7 @@ Bech32 and segwit addresses.")
;; the toplevel app called trezor-agent.
(package
(name "python-trezor-agent")
- (version "0.14.4")
+ (version "0.14.7")
(source
(origin
(method git-fetch)
@@ -934,7 +934,7 @@ Bech32 and segwit addresses.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ksv494xpga27ifrjyn1bkqaya5h769lqb9rx1ng0n4kvmnrqr3l"))))
+ (base32 "04dds5bbw73nk36zm8d02qw6qr92nrlcf8r1cq8ba96mzi34jbk0"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -962,8 +962,12 @@ Bech32 and segwit addresses.")
python-semver
python-unidecode
python-wheel))
- (native-inputs
- (list gnupg python-mock python-pytest))
+ (native-inputs ; Only needed for running the tests
+ (list gnupg
+ python-bech32
+ python-cryptography
+ python-mock
+ python-pytest))
(home-page "https://github.com/romanz/trezor-agent")
(synopsis "Use hardware wallets as SSH and GPG agent")
(description