aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-27 11:10:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-27 17:01:20 +0200
commit6ac6a7e0202e536b42756413d464f98e0c02f5c1 (patch)
tree72c517ed606933e03b472bc3d5d4aaeb43007c29 /gnu/packages/file.scm
parent0d41fe4855588fb659b8adafe215d5573517a79b (diff)
downloadguix-6ac6a7e0202e536b42756413d464f98e0c02f5c1.tar
guix-6ac6a7e0202e536b42756413d464f98e0c02f5c1.tar.gz
gnu: file: Update to 5.41.
* gnu/packages/file.scm (file): Absorb file-next. * gnu/packages/commencement.scm (file-boot0)[arguments]: Add make-flag to set CFLAGS. * gnu/packages/diffoscope.scm (diffoscope): Remove file-next. * gnu/packages/python-xyz.scm (python-magic)[inputs]: Replace file-next with file.
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 5e379d888b..3515258be4 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -32,14 +32,14 @@
(define-public file
(package
(name "file")
- (version "5.39")
+ (version "5.41")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.astron.com/pub/file/file-"
version ".tar.gz"))
(sha256
(base32
- "1lgs2w2sgamzf27kz5h7pajz7v62554q21fbs11n4mfrfrm2hpgh"))))
+ "0gv027jgdr0hdkw7m9ck0nwhq583f4aa7vnz4dzdbxv4ng3k5r8k"))))
(build-system gnu-build-system)
;; When cross-compiling, this package depends upon a native install of
@@ -58,15 +58,3 @@ extensions to tell you the type of a file, but looks at the actual contents
of the file. This package provides the libmagic library.")
(license bsd-2)
(home-page "https://www.darwinsys.com/file/")))
-
-(define-public file-next
- (package
- (inherit file)
- (version "5.41")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://ftp.astron.com/pub/file/file-"
- version ".tar.gz"))
- (sha256
- (base32
- "0gv027jgdr0hdkw7m9ck0nwhq583f4aa7vnz4dzdbxv4ng3k5r8k"))))))