aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
commitd030e42976545df8daaee5dcb8471928de249d38 (patch)
tree09805a9b3cfe7e833306d6ab8aa4a3eebc230fa9 /gnu/packages/file-systems.scm
parenta21ddf8192beb4ceb05af69c28980fd5f346e1a3 (diff)
downloadguix-d030e42976545df8daaee5dcb8471928de249d38.tar
guix-d030e42976545df8daaee5dcb8471928de249d38.tar.gz
gnu: bcachefs-tools: Support FUSE.
* gnu/packages/file-systems.scm (bcachefs-tools)[arguments]: Add a new 'enable-fuse phase. [inputs]: Add fuse. Change-Id: Ie82a361a4a6bfd0af7ce9c915bdc468f7aa06df2
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 0499c9f755..8a2255f078 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -723,7 +723,8 @@ performance and other characteristics.")
(license license:gpl2+)))
(define-public bcachefs-tools
- ;; The final public package with shell completion even when cross-compiling.
+ ;; The final public package with shell completion even when cross-compiling,
+ ;; as well as optional features such as FUSE (‘bcachefs fusemount’).
(package
(inherit bcachefs-tools-minimal)
(name "bcachefs-tools")
@@ -737,6 +738,10 @@ performance and other characteristics.")
(srfi srfi-26)))
((#:phases phases #~%standard-phases)
#~(modify-phases #$phases
+ (add-before 'build 'enable-fuse
+ (lambda _
+ ;; This must be an environment variable, not a make flag!
+ (setenv "BCACHEFS_FUSE" "1")))
(add-after 'install 'install-completions
(lambda* (#:key native-inputs #:allow-other-keys)
(define bcachefs
@@ -763,7 +768,10 @@ performance and other characteristics.")
(append (package-native-inputs bcachefs-tools-minimal)
(if (%current-target-system)
(list bcachefs-tools-minimal)
- (list))))))
+ (list))))
+ (inputs
+ (modify-inputs (package-inputs bcachefs-tools-minimal)
+ (append fuse)))))
(define-public bcachefs-tools-minimal/static
;; The static variant is public for consistency with the other file system