aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:03 +0200
commit09c14288cfe3f0017965d503841a938116c3372b (patch)
treeccefc966468bf2a08dec458329c523fa891040d4 /gnu/packages/file-systems.scm
parent31733c9090f8727a969869d9deeb702e6f996004 (diff)
downloadguix-09c14288cfe3f0017965d503841a938116c3372b.tar
guix-09c14288cfe3f0017965d503841a938116c3372b.tar.gz
gnu: bcachefs-tools: Respect input rewriting.
* gnu/packages/file-systems.scm (bcachefs-tools)[arguments]: Rewrite the 'promote-mount.bcachefs.sh phase to use SEARCH-INPUT-FILE.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 007203ae12..7788acd34e 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -614,16 +614,18 @@ from a mounted file system.")
(add-after 'install 'promote-mount.bcachefs.sh
;; XXX The (optional) ‘mount.bcachefs’ requires rust:cargo.
;; This shell alternative does the job well enough for now.
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define (whence file)
+ (dirname (search-input-file inputs file)))
(with-directory-excursion (string-append #$output "/sbin")
(rename-file "mount.bcachefs.sh" "mount.bcachefs")
;; WRAP-SCRIPT causes bogus ‘Insufficient arguments’ errors.
(wrap-program "mount.bcachefs"
`("PATH" ":" prefix
- ,(list (string-append #$output "/sbin")
- (string-append #$coreutils-minimal "/bin")
- (string-append #$gawk "/bin")
- (string-append #$util-linux "/bin"))))))))))
+ ,(list (getcwd)
+ (whence "bin/tail")
+ (whence "bin/awk")
+ (whence "bin/mount"))))))))))
(native-inputs
(append
(list pkg-config