aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/erlang-xyz.scm
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-05 13:44:39 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-05 17:14:51 +0400
commit1d8ff6cc614e701fbd16c93e9f2e22260f3208a9 (patch)
treed54529c078fb93ed521119559b1a4994dc98c674 /gnu/packages/erlang-xyz.scm
parent0ab5cdf2bdd93472a355c7baf792e1ecf7158a0b (diff)
downloadguix-1d8ff6cc614e701fbd16c93e9f2e22260f3208a9.tar
guix-1d8ff6cc614e701fbd16c93e9f2e22260f3208a9.tar.gz
gnu: Add erlang-p1-utils.
* gnu/packages/erlang-xyz.scm (erlang-p1-utils): New variable. Change-Id: I90bb3816c2c29c5c2f7a9eec3656967f63ae58b1 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/erlang-xyz.scm')
-rw-r--r--gnu/packages/erlang-xyz.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 1e5d87e833..954bd15773 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -62,6 +62,22 @@ Erlang and Elixir.")
(home-page "https://hex.pm/packages/jose")
(license license:expat)))
+(define-public erlang-p1-utils
+ (package
+ (name "erlang-p1-utils")
+ (version "1.0.26")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "p1_utils" version))
+ (sha256
+ (base32 "0k5hfqrjrvgh7gknqj5pzpra9k1g0bgc2ac19zb8pfan2669wdyh"))))
+ (build-system rebar-build-system)
+ (synopsis "ProcessOne utility modules for Erlang")
+ (description "This package provides ProcessOne utility modules for Erlang.")
+ (home-page "https://hex.pm/packages/p1_utils")
+ (license license:asl2.0)))
+
(define-public erlang-base64url
(package
(name "erlang-base64url")