aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
commitfd2f78f5fc062f7f4370d734857ed0fe146ecd9d (patch)
tree1c732d8ea714926a927c7dd9235dffe073048768 /gnu/packages/engineering.scm
parent4e64374743b962bcb566aa2f6dc86b36c05becde (diff)
downloadguix-fd2f78f5fc062f7f4370d734857ed0fe146ecd9d.tar
guix-fd2f78f5fc062f7f4370d734857ed0fe146ecd9d.tar.gz
gnu: minicom: Update to 2.9.
* gnu/packages/engineering.scm (minicom): Update to 2.9. [arguments]: Don't explicitly return #t from phases. [native-inputs]: Upgrade autoconf to autoconf-2.71.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index faba76161b..bdc4b179e1 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1487,7 +1487,7 @@ replacement for the OpenDWG libraries.")
(define-public minicom
(package
(name "minicom")
- (version "2.8")
+ (version "2.9")
(source
(origin
(method git-fetch)
@@ -1495,7 +1495,7 @@ replacement for the OpenDWG libraries.")
(url "https://salsa.debian.org/minicom-team/minicom.git")
(commit (string-append "v" version))))
(sha256
- (base32 "0kfihxbh9qkjk9m1932ajyqx384c2aj3d9yaphh3i9i7y1shxlpx"))
+ (base32 "18k0hiljsiq80x93c3qrd1cmcjjvsk1ymin03vncjp1v35xn8248"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -1508,15 +1508,13 @@ replacement for the OpenDWG libraries.")
(replace 'bootstrap
;; autogen.sh needlessly hard-codes aclocal-1.14.
(lambda _
- (invoke "autoreconf" "-vif")
- #t))
+ (invoke "autoreconf" "-vif")))
(add-before 'configure 'patch-lock-check
(lambda _
(substitute* "configure"
- (("test -d [$]UUCPLOCK") "true"))
- #t)))))
+ (("test -d [$]UUCPLOCK") "true")))))))
(native-inputs
- `(("autoconf" ,autoconf)
+ `(("autoconf" ,autoconf-2.71)
("automake" ,automake)
("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))