aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-17 11:21:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-17 11:22:36 +0300
commit0e467b7b0bc02860f2819e4eaf74f5cdae7e2cd1 (patch)
treed8d05a2a62105c6d8022e13627419d303be90447 /gnu/packages/engineering.scm
parent58452ecdb4e474cfbf09d6afdd2d58e5828061d3 (diff)
downloadguix-0e467b7b0bc02860f2819e4eaf74f5cdae7e2cd1.tar
guix-0e467b7b0bc02860f2819e4eaf74f5cdae7e2cd1.tar.gz
gnu: valeronoi: Reformat with guix style.
* gnu/packages/engineering.scm (valeronoi): Process package with guix style.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm83
1 files changed, 40 insertions, 43 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index e30face9e1..80fd9ac141 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1357,50 +1357,47 @@ the 'showing the effect of'-style of operation.")
(license license:gpl2+)))
(define-public valeronoi
-(package
- (name "valeronoi")
- (version "0.2.0")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/ccoors/Valeronoi")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1qkhrqkjsmm0h1bxf2ihkqfhdr18xx5x1i2ds1mla13zm0bw2570"))
- (snippet
- #~(begin (use-modules (guix build utils))
- (delete-file-recursively "3rdparty")
- (substitute* '("tests/test_colormap.cpp"
- "tests/test_main.cpp")
- (("catch\\.hpp") "catch2/catch.hpp"))))))
- (build-system cmake-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "./valeronoi-tests")))))))
- (inputs
- (list boost
- cgal
- gmp
- libxkbcommon
- mpfr
- openssl
- qtbase
- qtsvg))
- (native-inputs
- (list catch2))
- (home-page "https://github.com/ccoors/Valeronoi")
- (synopsis "WiFi mapping companion application for Valetudo")
- (description
- "Valeronoi (Valetudo + Voronoi) is a companion for Valetudo for generating
+ (package
+ (name "valeronoi")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ccoors/Valeronoi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qkhrqkjsmm0h1bxf2ihkqfhdr18xx5x1i2ds1mla13zm0bw2570"))
+ (snippet #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "3rdparty")
+ (substitute* '("tests/test_colormap.cpp"
+ "tests/test_main.cpp")
+ (("catch\\.hpp")
+ "catch2/catch.hpp"))))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./valeronoi-tests")))))))
+ (inputs (list boost
+ cgal
+ gmp
+ libxkbcommon
+ mpfr
+ openssl
+ qtbase
+ qtsvg))
+ (native-inputs (list catch2))
+ (home-page "https://github.com/ccoors/Valeronoi")
+ (synopsis "WiFi mapping companion application for Valetudo")
+ (description
+ "Valeronoi (Valetudo + Voronoi) is a companion for Valetudo for generating
WiFi signal strength maps. It visualizes them using a Voronoi diagram.")
- (license license:gpl3+)))
+ (license license:gpl3+)))
(define-public volk
(package