aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-23 13:08:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-23 19:29:25 +0200
commite6994d7e3f3f4a69f984c9e67df27abe1bc07c1c (patch)
tree42d7343beb810d0ec2e940877f1de0ca78681f32 /gnu/packages/embedded.scm
parent01d7fc9d566b456e343cc93dae23f0faa8f15f49 (diff)
downloadguix-e6994d7e3f3f4a69f984c9e67df27abe1bc07c1c.tar
guix-e6994d7e3f3f4a69f984c9e67df27abe1bc07c1c.tar.gz
gnu: gcc-arm-none-eabi-4.9: Fix incompatible redeclaration.
* gnu/packages/patches/gcc-4.9-inline.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/embedded.scm (gcc-arm-none-eabi-4.9)[source]: Use it.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index f2d0def2f2..5b3291f397 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -98,12 +98,14 @@
(base32
"113r98kygy8rrjfv2pd3z6zlfzbj543pq7xyq8bgh72c608mmsbr"))
- ;; Remove the one patch that doesn't apply to this 4.9 snapshot (the
- ;; patch is for 4.9.4 and later but this svn snapshot is older).
- (patches (remove (lambda (patch)
- (string=? (basename patch)
- "gcc-arm-bug-71399.patch"))
- (origin-patches (package-source xgcc))))))
+ (patches (cons (search-patch "gcc-4.9-inline.patch")
+ ;; Remove the one patch that doesn't apply to this 4.9
+ ;; snapshot (the patch is for 4.9.4 and later but this
+ ;; svn snapshot is older).
+ (remove (lambda (patch)
+ (string=? (basename patch)
+ "gcc-arm-bug-71399.patch"))
+ (origin-patches (package-source xgcc)))))))
(native-inputs
`(("flex" ,flex)
("gcc@5" ,gcc-5)