aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-09-07 09:59:32 +0200
committerRoel Janssen <roel@gnu.org>2017-09-07 09:59:32 +0200
commiteaff063aa0f478f23b78c5db8ba0d465b3f691cd (patch)
tree24426222a1259b30df2db2a0fc0c1b853ad375fc /gnu/packages/emacs.scm
parentc98f9c52960735da672d5e9766bdfef5ff136a6e (diff)
downloadguix-eaff063aa0f478f23b78c5db8ba0d465b3f691cd.tar
guix-eaff063aa0f478f23b78c5db8ba0d465b3f691cd.tar.gz
gnu: emacs-ess: Relocate the etc directory so that ESS can find it.
* gnu/packages/emacs.scm (emacs-ess): Relocate the etc directory so that ESS can find it.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm35
1 files changed, 19 insertions, 16 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9c0f9bc89a..abb99f8fc4 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3209,22 +3209,25 @@ E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
"0w7mbbajn377gdmvnd21mpyr368b2ia46gq6cb99y4y5rspf9pcg"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; There is no test suite.
- #:make-flags (list (string-append "PREFIX=" %output)
- (string-append "LISPDIR=" %output
- "/share/emacs/site-lisp/guix.d/ess"))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'more-shebang-patching
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "Makeconf"
- (("SHELL = /bin/sh")
- (string-append "SHELL = " (which "sh"))))))
- ;; FIXME: the texlive-union insists on regenerating fonts. It stores
- ;; them in HOME, so it needs to be writeable.
- (add-before 'build 'set-HOME
- (lambda _ (setenv "HOME" "/tmp") #t)))))
+ (let ((base-directory "/share/emacs/site-lisp/guix.d/ess"))
+ `(#:tests? #f ; There is no test suite.
+ #:make-flags (list (string-append "PREFIX=" %output)
+ (string-append "ETCDIR=" %output "/"
+ ,base-directory "/etc")
+ (string-append "LISPDIR=" %output "/"
+ ,base-directory))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'more-shebang-patching
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Makeconf"
+ (("SHELL = /bin/sh")
+ (string-append "SHELL = " (which "sh"))))))
+ ;; FIXME: the texlive-union insists on regenerating fonts. It stores
+ ;; them in HOME, so it needs to be writeable.
+ (add-before 'build 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp") #t))))))
(inputs
`(("emacs" ,emacs-minimal)
("r-minimal" ,r-minimal)))