aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorPeter Mikkelsen <petermikkelsen10@gmail.com>2017-08-24 13:52:20 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-31 14:57:53 +0200
commitb9dcaced16b7c01dfd8bd14b75b8496a5930a902 (patch)
treedce1bf3e3a7fd95731dd5cb684709c7c93b48265 /gnu/packages/emacs.scm
parentb6dc69af1de806e8b3a70e9a1afe0e1590da5480 (diff)
downloadguix-b9dcaced16b7c01dfd8bd14b75b8496a5930a902.tar
guix-b9dcaced16b7c01dfd8bd14b75b8496a5930a902.tar.gz
gnu: Add emacs-prop-menu.
* gnu/packages/emacs.scm (emacs-prop-menu): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1c3f8c137f..cca910af44 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2017 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
+;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5365,3 +5366,35 @@ enables you to easily define search engines, bind them to keybindings, and
query them from the comfort of your editor.")
(home-page "https://github.com/hrs/engine-mode")
(license license:gpl3+)))
+
+(define-public emacs-prop-menu
+ (package
+ (name "emacs-prop-menu")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://stable.melpa.org/packages/prop-menu-"
+ version ".el"))
+ (sha256
+ (base32
+ "01bk4sjafzz7gqrkv9jg0pa85qr34vbk3q8ga2b0m61bndywzgpr"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/david-christiansen/prop-menu-el")
+ (synopsis
+ "Create and display a context menu based on text and overlay properties")
+ (description
+ "This is a library for computing context menus based on text
+properties and overlays. The intended use is to have tools that
+annotate source code and others that use these annotations, without
+requiring a direct coupling between them, but maintaining
+discoverability.
+
+Major modes that wish to use this library should first define an
+appropriate value for @code{prop-menu-item-functions}. Then, they should
+bind @code{prop-menu-by-completing-read} to an appropriate
+key. Optionally, a mouse pop-up can be added by binding
+@code{prop-menu-show-menu} to a mouse event.")
+ (license license:gpl3+)))