aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2017-10-04 16:58:56 +0800
committerLeo Famulari <leo@famulari.name>2017-10-09 15:37:55 -0400
commit5b38c3e6d81a43c5ba93e8a90d52ae27a9437099 (patch)
tree5d8b800502bdb22434a0967fe85a2ba95d4a3016 /gnu/packages/emacs.scm
parent4c4f1871ae7005debf172edc66f80fcd98e35a90 (diff)
downloadguix-5b38c3e6d81a43c5ba93e8a90d52ae27a9437099.tar
guix-5b38c3e6d81a43c5ba93e8a90d52ae27a9437099.tar.gz
gnu: Add emacs-mustache.
* gnu/packages/emacs.scm (emacs-mustache): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 13c6f00d06..73ccf1bdc8 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4982,6 +4982,33 @@ containing words from the rime project.")
and cangjie.")
(license license:gpl2+)))
+(define-public emacs-mustache
+ (package
+ (name "emacs-mustache")
+ (version "0.23")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Wilfred/mustache.el/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0k9lcgil7kykkv1ylrgwy1g13ldjjmgi2cwmysgyb2vlj3jbwpdj"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-ht" ,emacs-ht)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/Wilfred/mustache.el")
+ (synopsis "Mustache templating library for Emacs")
+ (description "Mustache templating library for Emacs, mustache is
+a simple web template system, which is described as a logic-less system
+because it lacks any explicit control flow statements, both looping and
+conditional evaluation can be achieved using section tags processing lists
+and lambdas.")
+ (license license:gpl3+)))
+
(define-public emacs-xelb
(package
(name "emacs-xelb")