aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-21 21:25:43 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-22 00:17:42 +0100
commit4f028c8f95d621cf91b4d99acbf41a4e44775d21 (patch)
tree68207d1bdd9bf050513d6494e3b2130b1a2af40e /gnu/packages/emacs.scm
parentdc56970dde9d2c52f03d03b5d7d88616f9a836ea (diff)
downloadguix-4f028c8f95d621cf91b4d99acbf41a4e44775d21.tar
guix-4f028c8f95d621cf91b4d99acbf41a4e44775d21.tar.gz
gnu: Add Geiser.
* gnu/packages/emacs.scm (geiser): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm40
1 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 13a03ce365..6b2cda6e73 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -25,7 +25,8 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages gnutls)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages guile))
(define-public emacs
(package
@@ -91,3 +92,40 @@ reader, debugger interface, calendar, and more. Many of these
extensions are distributed with GNU Emacs; others are available
separately.")
(license gpl3+)))
+
+
+;;;
+;;; Emacs hacking.
+;;;
+
+(define-public geiser
+ (package
+ (name "geiser")
+ (version "0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/geiser/0.3/geiser-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1yzx0k1y5dq0m9dr3zdrxd8li0pddzblzj1ngd0spvsvvzz6v13j"))))
+ (build-system gnu-build-system)
+ (inputs `(("guile" ,guile-2.0)
+ ("emacs" ,emacs)))
+ (home-page "http://nongnu.org/geiser/")
+ (synopsis "Collection of Emacs modes for Guile and Racket hacking")
+ (description
+ "Geiser is a collection of Emacs major and minor modes that
+conspire with one or more Scheme interpreters to keep the Lisp Machine
+Spirit alive. It draws inspiration (and a bit more) from environments
+such as Common Lisp’s Slime, Factor’s FUEL, Squeak or Emacs itself, and
+does its best to make Scheme hacking inside Emacs (even more) fun.
+
+Or, to be precise, what i consider fun. Geiser is thus my humble
+contribution to the dynamic school of expression, and a reaction against
+what i perceive as a derailment, in modern times, of standard Scheme
+towards the static camp. Because i prefer growing and healing to poking
+at corpses, the continuously running Scheme interpreter takes the center
+of the stage in Geiser. A bundle of Elisp shims orchestrates the dialog
+between the Scheme interpreter, Emacs and, ultimately, the schemer,
+giving her access to live metadata.")
+ (license bsd-3)))