aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-21 12:56:36 -0300
committerVinicius Monego <monego@posteo.net>2024-07-28 10:49:15 -0300
commitb556eee0f1ffa91c074162457f3a9c0c868f4473 (patch)
tree58da73af436130e54bc21c33e6ef996fcb801faf /gnu/packages/emacs-xyz.scm
parent46a64c7fdd057283063aae6df058579bb07c4b6a (diff)
downloadguix-b556eee0f1ffa91c074162457f3a9c0c868f4473.tar
guix-b556eee0f1ffa91c074162457f3a9c0c868f4473.tar.gz
gnu: Add emacs-org-remark.
* gnu/packages/emacs-xyz.scm (emacs-org-remark): New variable. Change-Id: If7c5cca824f9b9a0c3f7fb0d39d0f73f0fe52460
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5639ed5fce..d4e60d0d5e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15190,6 +15190,41 @@ customizable 256 color support to @code{term} and @code{ansi-term}.")
efficient tabs plugin for Emacs with a lot of customization options.")
(license license:gpl3+)))
+(define-public emacs-org-remark
+ (package
+ (name "emacs-org-remark")
+ (version "1.2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nobiot/org-remark")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b6nmd64jzy6a7fz4x5p276sl36xa72y3ajbl72vr5ndqp94rlz1"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-org))
+ (home-page "https://nobiot.github.io/org-remark/")
+ (synopsis "Highlight & annotate text using Org mode")
+ (description "Org-remark lets you highlight and annotate text files,
+websites, EPUB books and Info documentation using Org mode.
+
+Features:
+
+@itemize
+@item Highlight and annotate any text file. The highlights and notes are kept
+in an Org file as the plain text database. This lets you easily manage your
+marginal notes and use the built-in Org facilities on them – e.g. create a
+sparse tree based on the category of the notes
+@item Create your your own highlighter pens with different colors, type (e.g.
+underline, squiggle, etc. optionally with Org’s category for search and filter
+on your highlights and notes)
+@item Have the same highlighting and annotating functionality for websites
+(when browsing with EWW), EPUB books with @code{nov.el}, Info documentation
+@end itemize")
+ (license license:gpl3+)))
+
(define-public emacs-mocker
(package
(name "emacs-mocker")