aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorRostislav Svoboda <rostislav.svoboda@gmail.com>2024-08-22 17:40:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-08-26 22:21:52 +0200
commit8fe362b69f91b718967accedf74dd447d372bf43 (patch)
tree6436b003d0cf3f8ac9549a53ebf26b64ac4fb8de /gnu/packages/emacs-xyz.scm
parent4b1b6e859a4076fa9929e2a9e66473ef3cfa1ef6 (diff)
downloadguix-8fe362b69f91b718967accedf74dd447d372bf43.tar
guix-8fe362b69f91b718967accedf74dd447d372bf43.tar.gz
gnu: Add emacs-composer.
* gnu/packages/emacs-xyz.scm (emacs-composer): New variable. Change-Id: Iafd56804d00923adb9e377b55575bbd61e97b358 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 418d92bcd2..e1176ab202 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19735,6 +19735,32 @@ guidelines. It also includes a couple handy IDE-type features such as
documentation search and a source and class browser.")
(license license:gpl3+)))
+(define-public emacs-composer
+ (let ((commit "791a7104be2ef2748757a186094c1e8f7f531a01")
+ (revision "0"))
+ (package
+ (name "emacs-composer")
+ (version (git-version "0.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zonuexe/composer.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01kb74nlkp4fvpbz6wdx776q3v7jfknhax1qmg85kj2ilkadfrd0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/zonuexe/composer.el")
+ (synopsis "Emacs interface for managing PHP dependencies with Composer")
+ (description
+ "This package provides an Emacs interface for working with PHP
+ dependencies managed by Composer. It allows users to run Composer commands
+ directly from Emacs, including installing and updating packages, and managing
+ Composer configurations. The package aims to streamline the development
+ workflow for PHP projects within Emacs.")
+ (license license:gpl3+))))
+
(define-public emacs-pippel
(let ((commit "cb194952ee150e77601d3233dabdb521b976ee79")
(revision "0"))