aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:06 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:54 +0200
commite46c530d506cff05138c44f0516d5c02a3664684 (patch)
tree662a083ae6b11e3260eb3bc3e4528d0b4ce70653 /gnu/packages/elm.scm
parent2ea11208f24a23d5aa9dd4b8639f0eec44c86705 (diff)
downloadguix-e46c530d506cff05138c44f0516d5c02a3664684.tar
guix-e46c530d506cff05138c44f0516d5c02a3664684.tar.gz
gnu: Add elm-parser.
* gnu/packages/elm.scm (elm-parser): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 68636c3192..4120fcaaf4 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -352,3 +352,23 @@ files, and work with file content.")
(description "This package enables Elm programs to make HTTP requests and
talk to servers.")
(license license:bsd-3)))
+
+(define-public elm-parser
+ (package
+ (name "elm-parser")
+ (version "1.1.0")
+ (source
+ (elm-package-origin
+ "elm/parser"
+ version
+ (base32 "06xx29rmagc5r45qfpvrd393lz83ylngidfp08432f1qc8y6r3lh")))
+ (build-system elm-build-system)
+ (propagated-inputs (list elm-core))
+ (home-page "https://package.elm-lang.org/packages/elm/parser/1.1.0")
+ (synopsis
+ "Parsing library for Elm")
+ (description
+ "Regular expressions are quite confusing and difficult to use. This
+library provides a coherent alternative that handles more cases and produces
+clearer code. It is focused on simplicity and great error messages.")
+ (license license:bsd-3)))