aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/elm.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 338008185d..ca7c61041b 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -58,27 +58,26 @@
(("(ansi-terminal|containers|network|http-client|language-glsl)\\s+[^,]+" all dep)
dep)))))))
(inputs
- `(("ghc-ansi-terminal" ,ghc-ansi-terminal)
- ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
- ("ghc-edit-distance" ,ghc-edit-distance)
- ("ghc-file-embed" ,ghc-file-embed)
- ("ghc-http" ,ghc-http)
- ("ghc-http-client" ,ghc-http-client)
- ("ghc-http-client-tls" ,ghc-http-client-tls)
- ("ghc-http-types" ,ghc-http-types)
- ("ghc-language-glsl" ,ghc-language-glsl)
- ("ghc-logict" ,ghc-logict)
- ("ghc-network" ,ghc-network)
- ("ghc-raw-strings-qq" ,ghc-raw-strings-qq)
- ("ghc-scientific" ,ghc-scientific)
- ("ghc-sha" ,ghc-sha)
- ("ghc-snap-core" ,ghc-snap-core)
- ("ghc-snap-server" ,ghc-snap-server)
- ("ghc-unordered-containers"
- ,ghc-unordered-containers)
- ("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-vector" ,ghc-vector)
- ("ghc-zip-archive" ,ghc-zip-archive)))
+ (list ghc-ansi-terminal
+ ghc-ansi-wl-pprint
+ ghc-edit-distance
+ ghc-file-embed
+ ghc-http
+ ghc-http-client
+ ghc-http-client-tls
+ ghc-http-types
+ ghc-language-glsl
+ ghc-logict
+ ghc-network
+ ghc-raw-strings-qq
+ ghc-scientific
+ ghc-sha
+ ghc-snap-core
+ ghc-snap-server
+ ghc-unordered-containers
+ ghc-utf8-string
+ ghc-vector
+ ghc-zip-archive))
(home-page "https://elm-lang.org")
(synopsis "Programming language for Web applications")
(description