aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:10:57 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:52 +0200
commit205457f814a9fe3e997777acb699d611472288d2 (patch)
tree81c3718f698b1ff48b7c38c83fc1c52403eb19e2 /gnu/packages/elm.scm
parent903c82583e1cec4c9ff09d5895c5cc646c37b661 (diff)
downloadguix-205457f814a9fe3e997777acb699d611472288d2.tar
guix-205457f814a9fe3e997777acb699d611472288d2.tar.gz
gnu: Add elm-virtual-dom.
* gnu/packages/elm.scm (elm-virtual-dom): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 4ad3a000cb..c2ccd6c557 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -158,3 +158,24 @@ such as @command{elm make} and @command{elm repl}.")
(delete 'build)
(delete 'validate-compiled))
#:implicit-elm-package-inputs? #f)))))
+
+(define-public elm-virtual-dom
+ (package
+ (name "elm-virtual-dom")
+ (version "1.0.3")
+ (source
+ (elm-package-origin
+ "elm/virtual-dom"
+ version
+ (base32 "1bjyyws7l0qvgp4ixzaimwriq86ncx5bvrzaksvjx3pv7bmkbx69")))
+ (build-system elm-build-system)
+ (propagated-inputs (list elm-json elm-core))
+ (home-page "https://package.elm-lang.org/packages/elm/virtual-dom/1.0.2")
+ (synopsis
+ "Elm's low-level virtual DOM implementation")
+ (description
+ "This package provides a virtual DOM implementation that backs Elm's
+core libraries for HTML and SVG. You should almost certainly use those
+higher-level libraries directly.")
+ (properties '((upstream-name . "elm/virtual-dom")))
+ (license license:bsd-3)))