aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:19 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:56 +0200
commit1b8d1f7d48f1d4cfb44fe1163e76609c8ee8e722 (patch)
treef3892a372a9f3fcbbb506befe47bb015bf803607 /gnu/packages/elm.scm
parent71841da6f7b1186bcaa43b12c30b533e2cecf966 (diff)
downloadguix-1b8d1f7d48f1d4cfb44fe1163e76609c8ee8e722.tar
guix-1b8d1f7d48f1d4cfb44fe1163e76609c8ee8e722.tar.gz
gnu: Add elm-ryannhg-date-format.
* gnu/packages/elm.scm (elm-ryannhg-date-format): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index a4fb99625a..a9b24b3b00 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -707,3 +707,25 @@ control how many digits after the decimal point are shown and how the
remaining digits are rounded. It rounds, floors and ceils the @dfn{common}
way (i.e. half up) or the @dfn{commerical} way (ie. half away from zero).")
(license license:bsd-3)))
+
+(define-public elm-ryannhg-date-format
+ (package
+ (name "elm-ryannhg-date-format")
+ (version "2.3.0")
+ (source
+ (elm-package-origin
+ "ryannhg/date-format"
+ version
+ (base32 "0razh6im5qwmla10knk67j8w11mqlqlyfnclykbfl06kaksfm3sp")))
+ (build-system elm-build-system)
+ (propagated-inputs (list elm-time elm-core))
+ (inputs (list elm-explorations-test))
+ (home-page
+ "https://package.elm-lang.org/packages/ryannhg/date-format/2.3.0")
+ (synopsis "Reliable advanced dates formatting for Elm")
+ (description
+ "This package provides Elm programs with reliable, powerful tools for
+formatting dates and times. It uses Elm's type system instead of format
+strings, which makes formatting code more readable and can catch some errors
+at compile time.")
+ (license license:bsd-3)))