aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-18 11:00:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-18 11:00:47 +0300
commite0f43c6a27d2930e95bae9710e369eb627ecbcf5 (patch)
tree480789d60e667fa754cd4edff3fed28bacbc0b70 /gnu/packages/elf.scm
parenta5c4b50c36846c5ced7978a176a5de6c6a142b18 (diff)
downloadguix-e0f43c6a27d2930e95bae9710e369eb627ecbcf5.tar
guix-e0f43c6a27d2930e95bae9710e369eb627ecbcf5.tar.gz
gnu: elfutils: Skip 3 more tests on riscv64-linux.
* gnu/packages/elf.scm (elfutils)[arugments]: When building for riscv64-linux skip 3 more failing tests.
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 6ef09399d4..d188099812 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
@@ -103,9 +103,15 @@
,@(if (target-riscv64?)
`((add-after 'unpack 'disable-failing-riscv64-test
(lambda _
- ;; dwfl_thread_getframes: No DWARF information found
(substitute* "tests/Makefile.in"
- (("run-backtrace-dwarf.sh") "")))))
+ ;; dwfl_thread_getframes: No DWARF information found
+ (("run-backtrace-dwarf.sh") "")
+ ;; These tests have several errors:
+ ;; unknown program header entry type 0x70000003
+ ;; '.riscv.attributes' has unsupported type 1879048195
+ (("run-reverse-sections-self.sh") "")
+ (("run-strip-strmerge.sh") "")
+ (("run-elflint-self.sh") "")))))
'()))))
(native-inputs (list m4))