aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/electronics.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-09-17 18:12:54 -0400
committerChristopher Baines <mail@cbaines.net>2023-09-25 11:30:03 +0100
commit9239c822469259509dbbc7a6966b5b265dd7c4f1 (patch)
tree1452effd4b1a19d45dae7113beb76245b82b12c0 /gnu/packages/electronics.scm
parentb2779b9f5cceb26940866d8d182fa5173fbee6eb (diff)
downloadguix-9239c822469259509dbbc7a6966b5b265dd7c4f1.tar
guix-9239c822469259509dbbc7a6966b5b265dd7c4f1.tar.gz
gnu: sigrok-firmware-fx2lafw: Update to 0.1.7-1.96b0b47.
This brings in eight commits[0] that improve the software in small ways, most importantly allowing it to build with the latest version of SDCC, 4.3.0 (patches to follow). Note the project's last formal release was in 2019. [0] http://sigrok.org/gitweb/?p=sigrok-firmware-fx2lafw.git;a=shortlog;h=96b0b47 * gnu/packages/electronics.scm (sigrok-firmware-fx2lafw): Update to 0.1.7-1.96b0b47. [source]: Switch to git-fetch. [native-inputs]: Add autoconf, automake. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/electronics.scm')
-rw-r--r--gnu/packages/electronics.scm49
1 files changed, 28 insertions, 21 deletions
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 2330a5922f..7d0e58aeae 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -121,27 +121,34 @@ to take care of the OS-specific details when writing software that uses serial p
(license license:gpl3+))))
(define-public sigrok-firmware-fx2lafw
- (package
- (name "sigrok-firmware-fx2lafw")
- (version "0.1.7")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://sigrok.org/download/source/sigrok-firmware-fx2lafw/"
- "sigrok-firmware-fx2lafw-" version ".tar.gz"))
- (sha256
- (base32
- "0fyfd82mvrcf55v5a3afq1mh1kfswk4c37qrbln6x92jm3b41x53"))))
- (build-system gnu-build-system)
- (arguments
- (list #:tests? #f)) ; no test suite
- (native-inputs
- (list sdcc))
- (home-page "https://www.sigrok.org/wiki/Fx2lafw")
- (synopsis "Firmware for Cypress FX2 chips")
- (description "Fx2lafw is free firmware for Cypress FX2 chips which makes them usable
-as simple logic analyzer and/or oscilloscope hardware.")
- (license license:gpl2+)))
+ ;; The project's last formal release was in 2019.
+ ;;
+ ;; The changes since then allow it to build with the latest version of SDCC,
+ ;; 4.3.0.
+ (let ((commit "96b0b476522c3f93a47ff8f479ec08105ba6a2a5")
+ (revision "1"))
+ (package
+ (name "sigrok-firmware-fx2lafw")
+ (version (git-version "0.1.7" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://sigrok.org/sigrok-firmware-fx2lafw")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n5nj2g2m5ih59591ny2drrv25zviqcwyx1cfdhy8ijl82yxjkmb"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f)) ; no test suite
+ (native-inputs
+ (list autoconf automake sdcc))
+ (home-page "https://www.sigrok.org/wiki/Fx2lafw")
+ (synopsis "Firmware for Cypress FX2 chips")
+ (description "Fx2lafw is free firmware for Cypress FX2 chips which makes
+them usable as simple logic analyzer and/or oscilloscope hardware.")
+ (license license:gpl2+))))
(define-public libsigrok
(let ((commit "a7e919a3a6b7fd511acbe1a280536b76c70c28d2")