aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/efi.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2023-05-29 17:53:41 -0400
committerJosselin Poiret <dev@jpoiret.xyz>2023-06-04 10:33:59 +0200
commitf72f3a909a41dce5dc4512c30d4cd0673bc6560f (patch)
tree8a77b8fcc4c03191662c0e0a1aeb9d957e7c3da2 /gnu/packages/efi.scm
parentb741218e919bfd386772322c1dcb286446bc4c90 (diff)
downloadguix-f72f3a909a41dce5dc4512c30d4cd0673bc6560f.tar
guix-f72f3a909a41dce5dc4512c30d4cd0673bc6560f.tar.gz
gnu: sbsigntools: Update to 0.9.5.
This fixes a build failure with openssl-3. * gnu/packages/efi.scm (sbsigntools): Update to 0.9.5. [arguments]: Remove trailing #t's. Use Gexps. Use "this-package-input". Simplify lambdas. [inputs]: Remove labels. Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
Diffstat (limited to 'gnu/packages/efi.scm')
-rw-r--r--gnu/packages/efi.scm59
1 files changed, 29 insertions, 30 deletions
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 75eb24bf86..499745eba1 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -30,6 +30,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -99,7 +100,7 @@ information.")
(define-public sbsigntools
(package
(name "sbsigntools")
- (version "0.9.4")
+ (version "0.9.5")
(source
(origin
(method git-fetch)
@@ -110,34 +111,32 @@ information.")
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "1y76wy65y6k10mjl2dm5hb5ms475alr4s080xzj8y833x01xvf3m"))))
+ (base32 "060n6w0dx1mrilhdv482ncckanqz6pdv53piimiki0bm15d2fcp4"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-more-shebangs
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "lib/ccan.git/tools/create-ccan-tree"
- (("#!/bin/bash")
- (string-append "#!"
- (assoc-ref inputs "bash")
- "/bin/bash")))
- #t))
- (add-after 'unpack 'patch
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* '("configure.ac"
- "tests/Makefile.am")
- (("/usr/include/efi")
- (string-append (assoc-ref inputs "gnu-efi")
- "/include/efi"))
- (("/usr/lib/gnuefi")
- (string-append (assoc-ref inputs "gnu-efi")
- "/lib")))
- #t))
- (add-after 'unpack 'setenv
- (lambda _
- (setenv "CC" "gcc")
- #t)))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-more-shebangs
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (substitute* "lib/ccan.git/tools/create-ccan-tree"
+ (("#!/bin/bash")
+ (string-append "#!"
+ (search-input-file (or native-inputs inputs)
+ "/bin/bash"))))))
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* '("configure.ac"
+ "tests/Makefile.am")
+ (("/usr/include/efi")
+ (string-append #$(this-package-input "gnu-efi")
+ "/include/efi"))
+ (("/usr/lib/gnuefi")
+ (string-append #$(this-package-input "gnu-efi")
+ "/lib")))))
+ (add-after 'unpack 'setenv
+ (lambda _
+ (setenv "CC" #$(cc-for-target)))))))
(native-inputs
(list autoconf
automake
@@ -146,9 +145,9 @@ information.")
pkg-config
util-linux)) ; getopt
(inputs
- `(("gnu-efi" ,gnu-efi)
- ("libuuid" ,util-linux "lib")
- ("openssl" ,openssl)))
+ (list gnu-efi
+ `(,util-linux "lib") ; libuuid
+ openssl))
(synopsis "EFI signing tools")
(description "This package provides tools for signing EFI binaries.")
(home-page "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git/")