aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/efi.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2021-01-12 20:37:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-01-12 22:08:33 +0100
commit373f808df229c12101301b766bd1810836b98481 (patch)
tree58075f78b882836175f341651a713dfe4c60b9a5 /gnu/packages/efi.scm
parentb8c3fa315a4140524d71bb12961ac83f300f1e17 (diff)
downloadguix-373f808df229c12101301b766bd1810836b98481.tar
guix-373f808df229c12101301b766bd1810836b98481.tar.gz
gnu: Add efi_analyzer.
* gnu/packages/engineering.scm (efi_analyzer): New variable. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/efi.scm')
-rw-r--r--gnu/packages/efi.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 12cadd6036..9582e65689 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -1,7 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,6 +62,40 @@ environment presented by Intel's EFI.")
;; Distribution is allowed only when accepting all those licenses.
(license (list license:bsd-2 license:bsd-3 license:bsd-4 license:expat))))
+(define-public efi_analyzer
+ (let ((commit "77c9e3a67cd7c2fca48a4292dad25a5429872f95")
+ (revision "0"))
+ (package
+ (name "efi_analyzer")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xypron/efi_analyzer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1izdkzybqyvzpzqz6kx4j7y47j6aa2dsdrychzgs65466x1a4br1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'support-cross-compilation
+ (lambda _
+ (substitute* "Makefile"
+ (("gcc") ,(cc-for-target)))
+ #t))
+ (delete 'configure)))) ; no configure script
+ (home-page "https://github.com/xypron/efi_analyzer")
+ (synopsis "Analyze EFI binaries")
+ (description
+ "The EFI Analyzer checks EFI binaries and prints out header and section
+information.")
+ (license license:bsd-2))))
+
(define-public sbsigntools
(package
(name "sbsigntools")