aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorM <matf@disr.it>2022-09-15 22:38:02 +0200
committerChristopher Baines <mail@cbaines.net>2022-09-16 12:21:32 +0200
commit2f95980b3c77aedd7f2ec4b12f75873e8e49f3ea (patch)
tree6ee4b10e5acb8f2044699597ca9bfe83d3278ffc /gnu/packages/ebook.scm
parent49e120272bf525793406916457b1c225a6dfef38 (diff)
downloadguix-2f95980b3c77aedd7f2ec4b12f75873e8e49f3ea.tar
guix-2f95980b3c77aedd7f2ec4b12f75873e8e49f3ea.tar.gz
gnu: Add shirah.
* gnu/packages/ebook.scm (shirah): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 8b0d669587..df4064ae56 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -697,3 +697,25 @@ format documents, with the following features:
(description
"Ebook library which can handle EPUB2/EPUB3 and Kindle format.")
(license license:agpl3+)))
+
+(define-public shirah
+ (package
+ (name "shirah")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "shirah_reader" version))
+ (sha256
+ (base32
+ "0j15v435lz68c1mj5clfx5dmfyjc6jvvz2q8hqvv799mb2faj42y"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-beautifulsoup4 python-ebooklib
+ python-syllables python-termcolor))
+ (home-page "https://github.com/hallicopter/shirah-reader")
+ (synopsis "Terminal ebook reader with an optional RSVP mode")
+ (description
+ "@command{shirah} is a curses based terminal ebook reader that can
+display ebooks in the usual way or with Rapid Serial Visual Presentation, a
+method to enable speedreading by showing the text word by word at configurable
+speeds.")
+ (license license:gpl2+)))