aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-12-26 15:55:16 -0500
committerChristopher Baines <mail@cbaines.net>2023-01-16 20:20:55 +0000
commita5c422f958f5991bb0f88bd871616dcd31ab0d8d (patch)
tree9059b49d54f6933a7d5d8b8dc2e2b9c4cc9f1ee6 /gnu/packages/documentation.scm
parentbc61a788b385d88b1365327bb11ece77fe5169b3 (diff)
downloadguix-a5c422f958f5991bb0f88bd871616dcd31ab0d8d.tar
guix-a5c422f958f5991bb0f88bd871616dcd31ab0d8d.tar.gz
gnu: latex2html: Update to 2022.2, use new package style.
* gnu/packages/documentation.scm (latex2html): Update to 2022.2. [arguments]: Use G-expressions. Remove trailing #t. Use #$output instead of assoc-ref. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm41
1 files changed, 19 insertions, 22 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 3ded8e1cac..f0cc10bc49 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -66,7 +66,7 @@
(define-public latex2html
(package
(name "latex2html")
- (version "2020.2")
+ (version "2022.2")
(source
(origin
(method git-fetch)
@@ -76,29 +76,26 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1icyl6kl60wh7cavprgbd8q6lpjwr7wn24m34kpiif7ahknhcbcm"))))
+ (base32 "1z71anjzxy5jsdlaqba4w9spncc6iycldarnr2z1dq8xmk6yhpjn"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-configure
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "configure"
- (("/usr/local")
- (assoc-ref outputs "out"))
- (("\\$\\{CONFIG_SHELL-/bin/sh\\}")
- (which "bash")))
- #t))
- (replace 'configure
- (lambda _
- (invoke "./configure")
- #t))
- (add-after 'configure 'patch-cfgcache
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "cfgcache.pm"
- (("/usr/local")
- (assoc-ref outputs "out")))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "configure"
+ (("/usr/local")
+ #$output)
+ (("\\$\\{CONFIG_SHELL-/bin/sh\\}")
+ (which "bash")))))
+ (replace 'configure
+ (lambda _
+ (invoke "./configure")))
+ (add-after 'configure 'patch-cfgcache
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "cfgcache.pm"
+ (("/usr/local")
+ #$output)))))))
(inputs
(list perl))
(synopsis "LaTeX documents to HTML")