aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-29 21:45:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-29 21:45:00 +0200
commit7696c8819f6e03d057e01ef004e9456ca22b89a3 (patch)
treed8a7c6d7c802f6433382c303fe9f6170ac133009 /gnu/packages/docker.scm
parentcd46757c1a0f886848fbb6828c028dd2a2532767 (diff)
downloadguix-7696c8819f6e03d057e01ef004e9456ca22b89a3.tar
guix-7696c8819f6e03d057e01ef004e9456ca22b89a3.tar.gz
gnu: docker-libnetwork-cmd-proxy: Skip tests on most architectures.
* gnu/packages/docker.scm (docker-libnetwork-cmd-proxy)[arguments]: Skip the tests unless building on x86_64-linux and not cross-building. Change-Id: I35028bd728920840370fe641240053baa3a4585f
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 3b809feb67..a69bbac168 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020, 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
@@ -299,7 +299,10 @@ the required network abstractions for applications.")
(inherit docker-libnetwork)
(name "docker-libnetwork-cmd-proxy")
(arguments
- `(#:import-path "github.com/docker/libnetwork/cmd/proxy"
+ ;; The tests are unsupported on all architectures except x86_64-linux.
+ `(#:tests? ,(and (not (%current-target-system))
+ (target-x86-64?))
+ #:import-path "github.com/docker/libnetwork/cmd/proxy"
#:unpack-path "github.com/docker/libnetwork"
#:install-source? #f))
(native-inputs