aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-06-30 17:01:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-06-30 17:02:23 +0200
commit902a48e0d3ce4a1983a6d3f71472639a8e59c48f (patch)
tree4c0158cf447cfbb8299ec112bce2f5cc8bef4a6c /gnu/packages/dns.scm
parent8af22b493199a17f46351c2f3d9f6ee759e48564 (diff)
downloadguix-902a48e0d3ce4a1983a6d3f71472639a8e59c48f.tar
guix-902a48e0d3ce4a1983a6d3f71472639a8e59c48f.tar.gz
gnu: Remove libasr.
It has been subsumed by OpenSMTPd and is otherwise unused. See <https://issues.guix.gnu.org/64271>. * gnu/packages/dns.scm (libasr): Delete variable. * gnu/packages/mail.scm (opensmtpd)[inputs]: Remove it to use the bundled ‘copy’.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index ac60e61976..3e7c47af6e 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -510,41 +510,6 @@ the two.")
license:gpl2
license:gpl3))))
-(define-public libasr
- (package
- (name "libasr")
- (version "1.0.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.opensmtpd.org/archives/"
- "libasr-" version ".tar.gz"))
- (sha256
- (base32 "1d6s8njqhvayx2gp47409sp1fn8m608ws26hr1srfp6i23nnpyqr"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-documentation
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (install-file "src/asr_run.3"
- (string-append out "/share/man/man3"))
- #t))))))
- (native-inputs
- (list autoconf automake libtool pkg-config))
- (home-page "https://www.opensmtpd.org")
- (synopsis "Asynchronous resolver library by the OpenBSD project")
- (description
- "libasr is a free, simple and portable asynchronous resolver library.
-It runs DNS queries and performs hostname resolution in a fully
-asynchronous fashion.")
- (license (list license:isc
- license:bsd-2 ; last part of getrrsetbyname_async.c
- license:bsd-3
- (license:non-copyleft "file://LICENSE") ; includes.h
- license:openssl))))
-
(define-public nsd
(package
(name "nsd")