aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-02-28 14:46:27 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2024-02-28 15:37:30 -0500
commit3013773366df063fcb81f0bc8b672451e60f19ca (patch)
tree8306e36dbd2324234569341ebee4c9aa9a1296e0 /gnu/packages/dns.scm
parentbc36327398440d8f65e72a82c8fe164ff36fdf06 (diff)
downloadguix-3013773366df063fcb81f0bc8b672451e60f19ca.tar
guix-3013773366df063fcb81f0bc8b672451e60f19ca.tar.gz
gnu: dnsmasq: Update to 2.90 [security fixes].
Fixes CVE 2023-50387 and CVE 2023-50868. * gnu/packages/dns.scm (dnsmasq): Update to 2.90. Change-Id: Id814dd2a562fe3c90673b98f7e0d6f3571988a90 Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: I191a62d62f202c65d7063eed0368affc115d82ca
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 73a2fac54b..fd90c9a751 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -293,7 +294,7 @@ prompt the user with the option to go with insecure DNS only.")
(define-public dnsmasq
(package
(name "dnsmasq")
- (version "2.89")
+ (version "2.90")
(source (origin
(method url-fetch)
(uri (string-append
@@ -301,7 +302,7 @@ prompt the user with the option to go with insecure DNS only.")
version ".tar.xz"))
(sha256
(base32
- "02dnxfnman38armn3sw56w80f9wb2vgm3qgm15crs2yg8q1j7g82"))))
+ "1r09l537vi867hlpv6vl7nvqhscvq1kf04m896bfrgrpv2dk0l4f"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))