aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-02-28 15:22:37 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2024-02-28 15:37:37 -0500
commit23283c50e96d7812a42b1272329fa3ba05a5a6e6 (patch)
treeac4a67ab5e06c6cc124bfe27b22023994f474727 /gnu/packages/dns.scm
parentf0d78aa47e4106a0820b458ef306340766d2ed74 (diff)
downloadguix-23283c50e96d7812a42b1272329fa3ba05a5a6e6.tar
guix-23283c50e96d7812a42b1272329fa3ba05a5a6e6.tar.gz
gnu: bind: Update to 9.19.21 [security fixes].
The current release fixes CVE-2023-50387 and other security issues. Previous releases fix many other security issues. * gnu/packages/dns.scm (bind): Update to 9.19.21. [source]: Remove 'patches' field. * gnu/packages/patches/bind-re-add-attr-constructor-priority.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it. Reported-by: Felix Lechner <felix.lechner@lease-up.com> Change-Id: I2415de88f16d9c952a1adcee5219980a3a19bb59
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 90a0fdf9de..84d3293c79 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -337,23 +337,23 @@ and BOOTP/TFTP for network booting of diskless machines.")
;; When updating, check whether isc-dhcp's bundled copy should be as well.
;; The BIND release notes are available here:
;; https://www.isc.org/bind/
- (version "9.16.38")
+ (version "9.19.21")
(source
(origin
(method url-fetch)
(uri (string-append "https://ftp.isc.org/isc/bind9/" version
"/bind-" version ".tar.xz"))
(sha256
- (base32 "03y52iyc2g63lkk9x2vaizpr0jv27g1z6mcxnjw8m8l4kaflrx4d"))
- (patches
- (search-patches "bind-re-add-attr-constructor-priority.patch"))))
+ (base32 "133f1aq8acaz9z03cl0gcrj4pq0hqm6c3sm4hz67d37phndsjs1b"))))
(build-system gnu-build-system)
(outputs `("out" "utils"))
(inputs
;; It would be nice to add GeoIP and gssapi once there are packages.
(list libcap
+ liburcu
libuv
libxml2
+ `(,nghttp2 "lib")
openssl
p11-kit
python