aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-07-16 19:47:48 +0100
committerLudovic Courtès <ludo@gnu.org>2023-08-16 23:14:04 +0200
commit1bd44b425b79e9da160b33a9b19d01973b44772e (patch)
treee7769bea0880c00263ca426812994ec3dee7f5c1 /gnu/packages/dns.scm
parent2b031ca4b2daa1d429e79b08e28fcd26e395bdf2 (diff)
downloadguix-1bd44b425b79e9da160b33a9b19d01973b44772e.tar
guix-1bd44b425b79e9da160b33a9b19d01973b44772e.tar.gz
gnu: ddclient: Remove package.
ddclient is unmaintained as of 2023-07-04 [1]. This reverts changes related to commit 0bc2d3e42b8800e875f24973f999739297f1f502. [1]: <https://github.com/ddclient/ddclient/issues/528> * gnu/packages/dns.scm (ddclient): Remove variable. * gnu/packages/patches/ddclient-skip-test.patch: Remove file. * gnu/local.mk: Unregister it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm71
1 files changed, 2 insertions, 69 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index fdd10a6611..d6bea61ca7 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
-;;; Copyright © 2018, 2022 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2022 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
@@ -91,8 +91,7 @@
#:use-module (guix build-system copy)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system meson)
- #:use-module (guix build-system trivial))
+ #:use-module (guix build-system meson))
(define-public cloudflare-cli
(let ((commit "2d986d3ec1b0e3158c4bd40e8918947cb74aa392")
@@ -1067,72 +1066,6 @@ LuaJIT, both a resolver library and a daemon.")
license:cc0
license:lgpl2.0))))
-(define-public ddclient
- (package
- (name "ddclient")
- (version "3.10.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ddclient/ddclient")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0l87d72apwrg6ipc9gix5gv64d4hr1ykxmss8x4r8d8mgj6j8rf1"))
- (modules '((guix build utils)))
- (snippet
- ;; XXX: erroneous version value, this is fixed in master
- #~(begin
- (substitute* "configure.ac"
- (("3.10.0_2") #$version))))
- (patches (search-patches "ddclient-skip-test.patch"))))
- (build-system gnu-build-system)
- (native-inputs
- (list autoconf automake libtool
- perl-test-warnings perl-test-mockmodule))
- (inputs
- (list inetutils ; logger
- net-tools
- bash-minimal ;for 'wrap-program'
- perl
- perl-digest-sha1
- perl-io-socket-ssl
- perl-io-socket-inet6 ;; XXX: this is likely to be removed in a future ddclient release
- ;; https://github.com/ddclient/ddclient/issues/461
- perl-json))
- (arguments
- (list
- #:configure-flags #~(list "--localstatedir=/var")
- #:phases
- #~(modify-phases %standard-phases
- (replace 'install
- (lambda _
- ;; XXX: Do not create /var
- (invoke "make" "localstatedir=/tmp/discard" "install")))
- (add-after 'wrap 'wrap-ddclient
- (lambda* (#:key inputs #:allow-other-keys)
- (wrap-program (string-append #$output "/bin/ddclient")
- `("PERL5LIB" ":" prefix ,(string-split (getenv "PERL5LIB") #\:))
- `("PATH" prefix ,(map (lambda (x)
- (string-append (assoc-ref inputs x) "/bin"))
- '("inetutils" "net-tools")))))))))
- (native-search-paths
- (list $SSL_CERT_DIR $SSL_CERT_FILE))
- (home-page "https://ddclient.net/")
- (synopsis "Address updating utility for dynamic DNS services")
- (description "This package provides a client to update dynamic IP
-addresses with several dynamic DNS service providers, such as
-@uref{https://www.dyndns.com/account/login.html,DynDNS.com}.
-
-This makes it possible to use a fixed hostname (such as myhost.dyndns.org) to
-access a machine with a dynamic IP address.
-
-The client supports both dynamic and (near) static services, as well as MX
-record and alternative name management. It caches the address, and only
-attempts the update when it has changed.")
- (license license:gpl2+)))
-
(define-public hnsd
(package
(name "hnsd")